summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-31 18:54:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-31 18:54:13 +0000
commitdef070c4ddb54459e879ea30690a7735657ca836 (patch)
tree867602423f0ca69dfbb1428fa50be5cb5bca6070 /kde-base/kopete
parentAdd patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630. (diff)
downloadgentoo-2-def070c4ddb54459e879ea30690a7735657ca836.tar.gz
gentoo-2-def070c4ddb54459e879ea30690a7735657ca836.tar.bz2
gentoo-2-def070c4ddb54459e879ea30690a7735657ca836.zip
Add patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog9
-rw-r--r--kde-base/kopete/files/digest-kopete-3.5.3-r46
-rw-r--r--kde-base/kopete/files/kopete-0.12.1-icqfix3.patch13
-rw-r--r--kde-base/kopete/kopete-3.5.3-r4.ebuild70
-rw-r--r--kde-base/kopete/kopete-3.5.4.ebuild5
5 files changed, 100 insertions, 3 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 44b2572e3c09..fbce581c83cd 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.72 2006/07/25 11:21:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.73 2006/07/31 18:54:13 flameeyes Exp $
+
+*kopete-3.5.3-r4 (31 Jul 2006)
+
+ 31 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kopete-0.12.1-icqfix3.patch, +kopete-3.5.3-r4.ebuild,
+ kopete-3.5.4.ebuild:
+ Add patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630.
*kopete-3.5.3-r3 (25 Jul 2006)
diff --git a/kde-base/kopete/files/digest-kopete-3.5.3-r4 b/kde-base/kopete/files/digest-kopete-3.5.3-r4
new file mode 100644
index 000000000000..0d9cb09f0130
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-3.5.3-r4
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 119af91a048c34d9a917a1898f215554 kdenetwork-3.5.3.tar.bz2 7524718
+RMD160 0c57f39652946c577ad0d6ec7f4fc593fe38a0bc kdenetwork-3.5.3.tar.bz2 7524718
+SHA256 f0323e33226b30ca30bfee05a9b6da8a1de964c9593d134294f83a54db0f4f3c kdenetwork-3.5.3.tar.bz2 7524718
diff --git a/kde-base/kopete/files/kopete-0.12.1-icqfix3.patch b/kde-base/kopete/files/kopete-0.12.1-icqfix3.patch
new file mode 100644
index 000000000000..ac786297eb5e
--- /dev/null
+++ b/kde-base/kopete/files/kopete-0.12.1-icqfix3.patch
@@ -0,0 +1,13 @@
+Index: kopete/protocols/oscar/liboscar/oscartypes.h
+===================================================================
+--- kopete/protocols/oscar/liboscar/oscartypes.h (revision 568242)
++++ kopete/protocols/oscar/liboscar/oscartypes.h (revision 568243)
+@@ -239,7 +239,7 @@
+ const WORD ICQ_MAJOR = 0x0014;
+ const WORD ICQ_MINOR = 0x0034;
+ const WORD ICQ_POINT = 0x0000;
+- const WORD ICQ_BUILD = 0x0A0F;
++ const WORD ICQ_BUILD = 0x0BB8;
+ const char ICQ_OTHER[] = { 0x00, 0x00, 0x04, 0x3d };
+ const char ICQ_COUNTRY[] = "us";
+ const char ICQ_LANG[] = "en";
diff --git a/kde-base/kopete/kopete-3.5.3-r4.ebuild b/kde-base/kopete/kopete-3.5.3-r4.ebuild
new file mode 100644
index 000000000000..13a438053b61
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.3-r4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.3-r4.ebuild,v 1.1 2006/07/31 18:54:13 flameeyes Exp $
+
+KMNAME=kdenetwork
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="sametime ssl xmms kernel_linux"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto
+ ) <virtual/x11-7 )"
+
+PATCHES="${FILESDIR}/${P}-icqfix.patch
+ ${FILESDIR}/${PN}-3.5.x-oscarcontacts.patch
+ ${FILESDIR}/${PN}-0.12.1-icqfix3.patch"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu"
+
+ kde-meta_src_compile
+}
diff --git a/kde-base/kopete/kopete-3.5.4.ebuild b/kde-base/kopete/kopete-3.5.4.ebuild
index 805295494dfd..5c28a6a0da44 100644
--- a/kde-base/kopete/kopete-3.5.4.ebuild
+++ b/kde-base/kopete/kopete-3.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.4.ebuild,v 1.2 2006/07/25 11:17:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.4.ebuild,v 1.3 2006/07/31 18:54:13 flameeyes Exp $
KMNAME=kdenetwork
MAXKDEVER=$PV
@@ -46,7 +46,8 @@ DEPEND="${BOTH_DEPEND}
x11-proto/scrnsaverproto
) <virtual/x11-7 )"
-PATCHES="${FILESDIR}/${PN}-3.5.x-oscarcontacts.patch"
+PATCHES="${FILESDIR}/${PN}-3.5.x-oscarcontacts.patch
+ ${FILESDIR}/${PN}-0.12.1-icqfix3.patch"
pkg_setup() {
if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then