summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 11:39:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 11:39:35 +0000
commit77256e9d235de89b6d4167b4fd0fb387197a456b (patch)
treee57055d35258ba1df56301efbb78f220ad96329c /kde-base/kopete
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-77256e9d235de89b6d4167b4fd0fb387197a456b.tar.gz
gentoo-2-77256e9d235de89b6d4167b4fd0fb387197a456b.tar.bz2
gentoo-2-77256e9d235de89b6d4167b4fd0fb387197a456b.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/files/digest-kopete-3.5.56
-rw-r--r--kde-base/kopete/kopete-3.5.5.ebuild68
3 files changed, 80 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 777ca204b896..176fdee4d202 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.77 2006/10/01 17:25:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.78 2006/10/03 11:39:35 flameeyes Exp $
+
+*kopete-3.5.5 (03 Oct 2006)
+
+ 03 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +kopete-3.5.5.ebuild:
+ Bump to 3.5.5 (pre-release).
01 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> kopete-3.5.2.ebuild,
kopete-3.5.3-r4.ebuild, kopete-3.5.4.ebuild:
diff --git a/kde-base/kopete/files/digest-kopete-3.5.5 b/kde-base/kopete/files/digest-kopete-3.5.5
new file mode 100644
index 000000000000..e013575200c5
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-3.5.5
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 a6e642c070cbd50d4a817f6588bf8e46 kdenetwork-3.5.5.tar.bz2 9235564
+RMD160 3e757d10ee5bf24b2ccf131e693fb614b9fdb9f4 kdenetwork-3.5.5.tar.bz2 9235564
+SHA256 c3f36e69bbd23902f2bdd9a1a8cda93b0436338ada422bb8ac6bc3d2bcd8e38f kdenetwork-3.5.5.tar.bz2 9235564
diff --git a/kde-base/kopete/kopete-3.5.5.ebuild b/kde-base/kopete/kopete-3.5.5.ebuild
new file mode 100644
index 000000000000..4e4b87279c76
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.5.ebuild,v 1.1 2006/10/03 11:39:35 flameeyes Exp $
+
+KMNAME=kdenetwork
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="sametime ssl xmms kernel_linux"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto
+ ) <virtual/x11-7 )"
+
+PATCHES="${FILESDIR}/${PN}-3.5.x-oscarcontacts.patch
+ ${FILESDIR}/${PN}-0.12.1-icqfix3.patch"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu"
+
+ kde-meta_src_compile
+}