summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-10-13 00:10:09 +0000
committerDan Armak <danarmak@gentoo.org>2005-10-13 00:10:09 +0000
commite2f3f14466e5bb3e2dd11e93d8694add86210e56 (patch)
tree7ec3323efaa88e487c6892d49033df8e61c201fc /kde-base/kontact/kontact-3.4.3.ebuild
parentModified 'cp' calls (bug #103487). (diff)
downloadgentoo-2-e2f3f14466e5bb3e2dd11e93d8694add86210e56.tar.gz
gentoo-2-e2f3f14466e5bb3e2dd11e93d8694add86210e56.tar.bz2
gentoo-2-e2f3f14466e5bb3e2dd11e93d8694add86210e56.zip
kde 3.4.3 split ebuilds
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'kde-base/kontact/kontact-3.4.3.ebuild')
-rw-r--r--kde-base/kontact/kontact-3.4.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/kontact/kontact-3.4.3.ebuild b/kde-base/kontact/kontact-3.4.3.ebuild
new file mode 100644
index 000000000000..e4c52eb1cb72
--- /dev/null
+++ b/kde-base/kontact/kontact-3.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-3.4.3.ebuild,v 1.1 2005/10/13 00:10:03 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+OLDDEPEND="~kde-base/libkdepim-$PV"
+DEPEND="
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkpimidentities)"
+
+KMCOPYLIB="libkdepim libkdepim/
+ libkpimidentities.la libkpimidentities/"
+KMEXTRACTONLY="libkdepim/
+ libkpimidentities/
+ kontact/plugins/"
+KMEXTRA="
+ kontact/plugins/newsticker/
+ kontact/plugins/summary/
+ kontact/plugins/weather/"
+# We remove some plugins that are related to external kdepim's programs, because they needs also libs from korganizer, kpilot etc... so to emerge kontact we'll need also ALL the other programs, it's better to emerge the kontact's plugins in the ebuild of its program
+