summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
commitd184f1ab9f020bfde5c438ef4619ca58de2159f7 (patch)
tree7d64a3c945eda98cf0dbc517b9c12bbccf4f6c1e /kde-base/kdeplasma-addons
parentVersion bump (diff)
downloadgentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.gz
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.bz2
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.zip
Version bump KDE SC 4.14.2
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.14.2.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index f4baf32b9f29..51571b2f2a91 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.262 2014/09/16 18:17:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.263 2014/10/25 19:58:27 kensington Exp $
+
+*kdeplasma-addons-4.14.2 (25 Oct 2014)
+
+ 25 Oct 2014; Michael Palimaka <kensington@gentoo.org>
+ +kdeplasma-addons-4.14.2.ebuild:
+ Version bump KDE SC 4.14.2
*kdeplasma-addons-4.14.1 (16 Sep 2014)
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.2.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.2.ebuild
new file mode 100644
index 000000000000..e83859e98846
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.2.ebuild,v 1.1 2014/10/25 19:58:27 kensington Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus json +kdepim nepomuk oauth
+qalculate qwt scim"
+
+RESTRICT=test
+# tests hang
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'nepomuk?')
+ $(add_kdebase_dep krunner '' 4.11)
+ $(add_kdebase_dep plasma-workspace 'nepomuk?' 4.11)
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ json? ( dev-libs/qjson )
+ kdepim? ( $(add_kdebase_dep kdepimlibs) )
+ oauth? ( dev-libs/qoauth )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_build ibus)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_build scim)
+ )
+
+ kde4-base_src_configure
+}