summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
commitad239490ed9eef8b7e06727b919d4593f51667ae (patch)
tree86688474b00c8427904e72d675cbe3d82b38d1c2 /kde-base/kdepimlibs
parentVersion bump. (diff)
downloadgentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.gz
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.bz2
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.zip
Version bump KDE SC 4.13.1
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.13.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index c698de595335..8e79ff3fa256 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.267 2014/05/08 21:09:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.268 2014/05/13 17:43:17 johu Exp $
+
+*kdepimlibs-4.13.1 (13 May 2014)
+
+ 13 May 2014; Johannes Huber <johu@gentoo.org> +kdepimlibs-4.13.1.ebuild:
+ Version bump KDE SC 4.13.1
08 May 2014; Johannes Huber <johu@gentoo.org>
-files/kdepimlibs-4.11.2-sentuuid.patch, -kdepimlibs-4.11.5.ebuild:
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.13.1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.13.1.ebuild
new file mode 100644
index 000000000000..5c3dfa6252c1
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.13.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.13.1.ebuild,v 1.1 2014/05/13 17:43:17 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap prison"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ !kde-misc/akonadi-social-utils
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.12.1
+ >=dev-libs/boost-1.35.0-r5:=
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.48-r2:=
+ dev-libs/cyrus-sasl
+ >=dev-libs/qjson-0.8.1
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ prison? ( media-libs/prison )
+ ldap? ( net-nds/openldap )
+"
+# boost is not linked to, but headers which include it are installed
+# bug #418071
+RDEPEND="${DEPEND}
+ !=kde-base/kdepim-runtime-4.10*
+ !=kde-base/kdepim-runtime-4.11*
+ !<kde-base/kdepim-runtime-4.4.11.1-r2
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-boostincludes.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_find_package ldap)
+ $(cmake-utils_use_find_package prison)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake #Collides with net-im/choqok
+}