summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-05-15 16:30:23 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-05-15 16:30:23 +0000
commit929b48b707eb4aa9c5ca8e2dfc33a2cf44bce66d (patch)
tree62bd4919fa4620363c51dcb8aed62a8bbb9a7547 /kde-base/kdepim-runtime
parentSync with KDE overlay - update SRC_URI. (diff)
downloadgentoo-2-929b48b707eb4aa9c5ca8e2dfc33a2cf44bce66d.tar.gz
gentoo-2-929b48b707eb4aa9c5ca8e2dfc33a2cf44bce66d.tar.bz2
gentoo-2-929b48b707eb4aa9c5ca8e2dfc33a2cf44bce66d.zip
Version bump.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog8
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.14.8.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 8bb3ebf0fbe8..e5da3b36e831 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.233 2015/03/29 13:14:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.234 2015/05/15 16:30:23 kensington Exp $
+
+*kdepim-runtime-4.14.8 (15 May 2015)
+
+ 15 May 2015; Michael Palimaka <kensington@gentoo.org>
+ +kdepim-runtime-4.14.8.ebuild:
+ Version bump.
*kdepim-runtime-4.14.6 (29 Mar 2015)
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.14.8.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.14.8.ebuild
new file mode 100644
index 000000000000..77b20a2062d0
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.14.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.14.8.ebuild,v 1.1 2015/05/15 16:30:23 kensington Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+EGIT_BRANCH="KDE/4.14"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ >=app-office/akonadi-server-1.12.90
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( >=net-libs/libkolab-0.5 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}