summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-02 20:09:59 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-02 20:09:59 +0000
commit36f97dae47c650b95e023be26e583a96919eda4c (patch)
tree45dc2d79b6558b2ba0d90875dab3f95f9a94edac /kde-base/kdenetwork
parentversion bump (diff)
downloadgentoo-2-36f97dae47c650b95e023be26e583a96919eda4c.tar.gz
gentoo-2-36f97dae47c650b95e023be26e583a96919eda4c.tar.bz2
gentoo-2-36f97dae47c650b95e023be26e583a96919eda4c.zip
version bump
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'kde-base/kdenetwork')
-rw-r--r--kde-base/kdenetwork/ChangeLog8
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.5.33
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.3.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/kde-base/kdenetwork/ChangeLog b/kde-base/kdenetwork/ChangeLog
index 82a21038a9e9..7c759c79f062 100644
--- a/kde-base/kdenetwork/ChangeLog
+++ b/kde-base/kdenetwork/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdenetwork
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.204 2006/06/01 10:51:40 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.205 2006/06/02 20:09:59 genstef Exp $
+
+*kdenetwork-3.5.3 (02 Jun 2006)
+
+ 02 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ +kdenetwork-3.5.3.ebuild:
+ version bump
01 Jun 2006; Thomas Cort <tcort@gentoo.org> kdenetwork-3.5.2.ebuild:
Stable on alpha wrt Bug #132213.
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3 b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3
new file mode 100644
index 000000000000..f3c8e6b3f3c0
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3
@@ -0,0 +1,3 @@
+MD5 119af91a048c34d9a917a1898f215554 kdenetwork-3.5.3.tar.bz2 7524718
+RMD160 0c57f39652946c577ad0d6ec7f4fc593fe38a0bc kdenetwork-3.5.3.tar.bz2 7524718
+SHA256 f0323e33226b30ca30bfee05a9b6da8a1de964c9593d134294f83a54db0f4f3c kdenetwork-3.5.3.tar.bz2 7524718
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild
new file mode 100644
index 000000000000..cb5483862f0c
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild,v 1.1 2006/06/02 20:09:59 genstef Exp $
+
+inherit kde-dist eutils flag-o-matic
+
+DESCRIPTION="KDE network apps: kopete, kppp, kget..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="rdesktop sametime slp ssl wifi xmms"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ slp? ( net-libs/openslp )
+ wifi? ( net-wireless/wireless-tools )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ ) virtual/x11 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ rdesktop? ( >=net-misc/rdesktop-1.4.1 )
+ dev-lang/perl
+ ssl? ( dev-perl/IO-Socket-SSL
+ app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto
+ ) virtual/x11 )
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/kppp-3.5.0-bindnow.patch
+ ${FILESDIR}/lisa-3.5.0-bindnow.patch"
+
+src_compile() {
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+
+ local myconf="--with-libidn
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi)
+ $(use_with xmms) --without-external-libgadu"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ chmod u+s ${D}/${KDEDIR}/bin/reslisa
+
+ # empty config file needed for lisa to work with default settings
+ dodir /etc
+ touch ${D}/etc/lisarc
+
+ # lisa, reslisa initscripts
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${T}/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${T}/reslisa
+ exeinto /etc/init.d
+ doexe ${T}/lisa ${T}/reslisa
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+}