summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-11-19 21:26:53 +0000
committerDan Armak <danarmak@gentoo.org>2002-11-19 21:26:53 +0000
commit431dfc8b7de45c5ae56b8d46090374ea49913bce (patch)
tree296b33dc1592b4701d1a526498781f6af05a5f0f /kde-base/kdemultimedia
parentMade plugin dir FHS compliant (diff)
downloadgentoo-2-431dfc8b7de45c5ae56b8d46090374ea49913bce.tar.gz
gentoo-2-431dfc8b7de45c5ae56b8d46090374ea49913bce.tar.bz2
gentoo-2-431dfc8b7de45c5ae56b8d46090374ea49913bce.zip
the rest of the kde 3.1 ebuilds
Diffstat (limited to 'kde-base/kdemultimedia')
-rw-r--r--kde-base/kdemultimedia/files/kdemultimedia-3.1-gentoo-timidity.diff21
-rw-r--r--kde-base/kdemultimedia/files/kdemultimedia-3.1-ln-sf.diff29
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.1.ebuild70
3 files changed, 120 insertions, 0 deletions
diff --git a/kde-base/kdemultimedia/files/kdemultimedia-3.1-gentoo-timidity.diff b/kde-base/kdemultimedia/files/kdemultimedia-3.1-gentoo-timidity.diff
new file mode 100644
index 000000000000..f392a244212e
--- /dev/null
+++ b/kde-base/kdemultimedia/files/kdemultimedia-3.1-gentoo-timidity.diff
@@ -0,0 +1,21 @@
+diff -ru kdemultimedia-2.2.1.orig/kmidi/TIMIDITY/motif_p.c kdemultimedia-2.2.1/kmidi/TIMIDITY/motif_p.c
+--- kmidi/TIMIDITY/motif_p.c Mon Feb 28 19:07:37 2000
++++ kmidi/TIMIDITY/motif_p.c Fri Oct 19 04:00:10 2001
+@@ -22,6 +22,7 @@
+ pipe communication between motif interface and sound generator
+
+ */
++#include <sys/errno.h>
+ #ifdef IA_MOTIF
+
+ #include <stdio.h>
+--- kmidi/TIMIDITY/tk_c.c 2002-04-04 21:15:35.000000000 -0600
++++ kmidi/TIMIDITY/tk_c.c 2002-04-04 21:17:06.000000000 -0600
+@@ -12,6 +12,7 @@
+ *================================================================*/
+ #ifdef TCLTK
+
++#include <sys/errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/kde-base/kdemultimedia/files/kdemultimedia-3.1-ln-sf.diff b/kde-base/kdemultimedia/files/kdemultimedia-3.1-ln-sf.diff
new file mode 100644
index 000000000000..ee6daa91f3dc
--- /dev/null
+++ b/kde-base/kdemultimedia/files/kdemultimedia-3.1-ln-sf.diff
@@ -0,0 +1,29 @@
+--- kmidi/TIMIDITY/makelinks Sat Aug 24 11:36:27 2002
++++ kmidi/TIMIDITY/makelinks Sat Aug 24 11:36:15 2002
+@@ -3,7 +3,7 @@ srcdir=$1
+ for header in common config controls ctl effects filter instrum mix \
+ output playmidi readmidi resample sbk sflayer tables \
+ version ; do
+- if [ ! -h ${header}.h ]; then ln -s ${srcdir}/${header}.h . ; fi
++ if [ ! -h ${header}.h ]; then ln -sf ${srcdir}/${header}.h . ; fi
+ done
+
+ for cfile in alsa_a arts_a b_out bag bsd20_a celeste_e chorus_e \
+@@ -13,14 +13,14 @@ for cfile in alsa_a arts_a b_out bag bsd
+ playmidi raw_a readmidi readsbk resample resample_f \
+ resample_l reverb_e sbktext sf2cfg slang_c sndfont \
+ sun_a tables timidity wav2pat wave_a ; do
+- if [ ! -h ${cfile}.c ]; then ln -s ${srcdir}/${cfile}.cpp ${cfile}.c ; fi
++ if [ ! -h ${cfile}.c ]; then ln -sf ${srcdir}/${cfile}.cpp ${cfile}.c ; fi
+ done
+
+ for lfile in cfg ; do
+- if [ ! -h ${lfile}.l ]; then ln -s ${srcdir}/${lfile}.l . ; fi
++ if [ ! -h ${lfile}.l ]; then ln -sf ${srcdir}/${lfile}.l . ; fi
+ done
+
+ # LEAVE THIS ONE AT THE END!!
+ for other in BITMAPS ; do
+- if [ ! -h ${other} ]; then ln -s ${srcdir}/${other} . ; fi
++ if [ ! -h ${other} ]; then ln -sf ${srcdir}/${other} . ; fi
+ done
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.1.ebuild
new file mode 100644
index 000000000000..4f637cc60195
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.1.ebuild,v 1.1 2002/11/19 21:26:53 danarmak Exp $
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="KDE $PV - multimedia apps"
+KEYWORDS="x86"
+
+newdepend ">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ slang? ( >=sys-libs/slang-1.4.4 )
+ >=media-sound/mpg123-0.59r
+ tcltk? ( >=dev-lang/tk-8.0.5-r2 )
+ >=dev-libs/glib-1.3.3
+ oggvorbis? ( media-libs/libvorbis )"
+ #>=media-libs/xine-lib-0.9.14" # not yet available
+ #gtk? ( =x11-libs/gtk+-1.2* )
+# alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+RDEPEND="$RDEPEND
+ cdr? ( app-cdr/cdrtools
+ >=app-cdr/cdrdao-1.1.5 )"
+
+replace-flags "-O3" "-O2"
+
+myaudio="--enable-audio=oss"
+myinterface="--enable-interface=xaw,ncurses"
+myconf="$myconf --enable-xaw --enable-ncurses"
+#myconf="$myconf --with-xine-prefix=/usr"
+
+# make -j2 fails
+#export MAKEOPTS="-j1"
+PATCHES="$FILESDIR/$P-gentoo-timidity.diff
+ $FILESDIR/$P-ln-sf.diff"
+
+# alsa 0.9 not supported
+#use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa" || myconf="$myconf --without-alsa --disable-alsa"
+use nas && myaudio="$myaudio,nas --with-nas-library=/usr/X11R6/lib/libaudio.so --with-nas-includes=/usr/X11R6/include" || myconf="$myconf --disable-nas"
+use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
+use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
+# kmidi/TIMIDITY miscompiles with gtk
+#use gtk && myinterface="$myinterface,gtk" && myconf="$myconf --enable-gtk"
+use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
+use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
+use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+
+use cdr || KDE_REMOVE_DIR="kaudiocreator"
+
+# xine doesn't compile yet
+# also turn off kaudiocreator if cdr isn't in use
+KDE_REMOVE_DIR="xine_artsplugin"
+[ -z "`use cdr`" ] && KDE_REMOVE_DIR="$KDE_REMOVE_DIR kaudiocreator"
+
+myconf="$myconf $myaudio $myinterface"
+
+pkg_postinst() {
+
+ if [ -n "`use alsa`" ]; then
+ einfo "WARNING: alsa support has been removed becuase of a bug in kdemm sources.
+For further information see bug #2324 on bugs.gentoo.org and bug #39574 on bugs.kde.org.
+Meanwhile, you can use the alsa oss emulation."
+ fi
+ return 0
+
+}