summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 22:51:25 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 22:51:25 +0000
commit2874e4041bec71690e96a7635804d86dca5b7c0f (patch)
tree7ec677198ab1c265b0dbc0ce07dae0898c1535e4 /kde-base/kdemultimedia-kioslaves
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-2874e4041bec71690e96a7635804d86dca5b7c0f.tar.gz
gentoo-2-2874e4041bec71690e96a7635804d86dca5b7c0f.tar.bz2
gentoo-2-2874e4041bec71690e96a7635804d86dca5b7c0f.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdemultimedia-kioslaves')
-rw-r--r--kde-base/kdemultimedia-kioslaves/ChangeLog8
-rw-r--r--kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.5.9.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/kdemultimedia-kioslaves/ChangeLog b/kde-base/kdemultimedia-kioslaves/ChangeLog
index 4fbbb12af041..b74b88ca8359 100644
--- a/kde-base/kdemultimedia-kioslaves/ChangeLog
+++ b/kde-base/kdemultimedia-kioslaves/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdemultimedia-kioslaves
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.88 2008/02/17 03:24:25 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.89 2008/02/20 22:51:25 philantrop Exp $
+
+*kdemultimedia-kioslaves-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdemultimedia-kioslaves-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
17 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-kdemultimedia-kioslaves-3.5.5.ebuild,
diff --git a/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.5.9.ebuild b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.5.9.ebuild
new file mode 100644
index 000000000000..849151be0d0f
--- /dev/null
+++ b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.5.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.5.9.ebuild,v 1.1 2008/02/20 22:51:25 philantrop Exp $
+
+KMNAME=kdemultimedia
+KMMODULE=kioslave
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="kioslaves from kdemultimedia package"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="encode flac mp3 vorbis"
+DEPEND=">=kde-base/libkcddb-${PV}:${SLOT}
+ media-sound/cdparanoia
+ media-libs/taglib
+ encode? ( vorbis? ( media-libs/libvorbis )
+ flac? ( >=media-libs/flac-1.1.2 ) )"
+RDEPEND="${DEPEND}
+ encode? ( mp3? ( media-sound/lame ) )"
+
+KMCOPYLIB="libkcddb libkcddb"
+KMEXTRACTONLY="akode/configure.in.in"
+KMCOMPILEONLY="
+ kscd
+ kscd/libwm
+ libkcddb"
+
+PATCHES="${FILESDIR}/kdemultimedia-3.5.5+flac-1.1.3.patch
+ ${FILESDIR}/kdemultimedia-kioslaves-3.5.6-arts.patch
+ ${FILESDIR}/kdemultimedia-kioslaves-3.5.8-freebsd.patch"
+
+src_compile() {
+ myconf="--with-cdparanoia --enable-cdparanoia"
+ if use encode; then
+ myconf="$myconf $(use_with vorbis) $(use_with flac)"
+ else
+ myconf="$myconf --without-vorbis --without-flac"
+ fi
+
+ DO_NOT_COMPILE="libkcddb kscd" kde-meta_src_compile myconf configure
+ cd "${S}"/libkcddb && emake configbase.h cdinfodialogbase.h
+
+ # Library deps seems not to be built as they should :/
+ cd "${S}"/kscd/libwm/audio && emake libworkmanaudio.la && \
+ cd "${S}"/kscd/libwm && emake libworkman.la && \
+ cd "${S}"/kscd && emake libkcompactdisc.la || \
+ die "failed to make prerequisite libraries."
+
+ DO_NOT_COMPILE="libkcddb kscd" kde-meta_src_compile make
+}