summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
commitd184f1ab9f020bfde5c438ef4619ca58de2159f7 (patch)
tree7d64a3c945eda98cf0dbc517b9c12bbccf4f6c1e /kde-base/kdebase-data
parentVersion bump (diff)
downloadgentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.gz
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.bz2
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.zip
Version bump KDE SC 4.14.2
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/kdebase-data')
-rw-r--r--kde-base/kdebase-data/ChangeLog8
-rw-r--r--kde-base/kdebase-data/kdebase-data-4.14.2.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kdebase-data/ChangeLog b/kde-base/kdebase-data/ChangeLog
index 15ddb5e20d6b..c6372f2ec04b 100644
--- a/kde-base/kdebase-data/ChangeLog
+++ b/kde-base/kdebase-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebase-data
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-data/ChangeLog,v 1.333 2014/09/16 18:17:23 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-data/ChangeLog,v 1.334 2014/10/25 19:58:37 kensington Exp $
+
+*kdebase-data-4.14.2 (25 Oct 2014)
+
+ 25 Oct 2014; Michael Palimaka <kensington@gentoo.org>
+ +kdebase-data-4.14.2.ebuild:
+ Version bump KDE SC 4.14.2
*kdebase-data-4.14.1 (16 Sep 2014)
diff --git a/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild b/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild
new file mode 100644
index 000000000000..8e31b72e76cf
--- /dev/null
+++ b/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild,v 1.1 2014/10/25 19:58:37 kensington Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase"
+IUSE="+wallpapers"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ wallpapers? ( $(add_kdebase_dep kde-wallpapers) )
+ $(add_kdebase_dep oxygen-icons)
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}