summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commitb0cf2ebbfc7626d65b374788654d4e26028bda3f (patch)
tree473933e2eaf30d14938b24846be4b834a0d385d4 /kde-base/kde-l10n
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadgentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.gz
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.bz2
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.zip
Version bump to KDE 4.0.1.
(Portage version: 2.1.4.1)
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog8
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.0.1.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 6d5dea6d4486..602e00473e41 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.1 2008/01/17 23:49:11 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.2 2008/02/07 00:11:25 philantrop Exp $
+
+*kde-l10n-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kde-l10n-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
*kde-l10n-4.0.0 (17 Jan 2008)
diff --git a/kde-base/kde-l10n/kde-l10n-4.0.1.ebuild b/kde-base/kde-l10n/kde-l10n-4.0.1.ebuild
new file mode 100644
index 000000000000..84dc9f31f524
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.0.1.ebuild,v 1.1 2008/02/07 00:11:25 philantrop Exp $
+
+EAPI="1"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gettext-0.15"
+RDEPEND=""
+
+LANGS="ar be bg ca cs csb da de el en_GB eo es et eu fi fr fy ga gl hi hu it ja
+kk km ko lv mk nb nds ne nl nn pa pl pt pt_BR ru se sl sv th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+ SRC_URI="${SRC_URI} linguas_${X}? ( ${URI_BASE}/${PN}-${X}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ if [[ -z ${A} ]]; then
+ echo
+ ewarn "You either have the LINGUAS variable unset, or it only"
+ ewarn "contains languages not supported by ${P}."
+ ewarn "You won't have any additional language support."
+ echo
+ ewarn "${P} supports these language codes:"
+ ewarn "${LANGS}"
+ echo
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # Create a top-level CMakeLists.txt to include the selected LINGUAS as sub-directories of ${S}
+ for dir in * ; do
+ [[ -d ${dir} ]] && echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ done
+}
+
+src_compile() {
+ if [[ -n ${A} ]]; then
+ kde4-base_src_compile
+ fi
+}
+
+src_install() {
+ if [[ -n ${A} ]]; then
+ kde4-base_src_install
+ fi
+}