summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:16:23 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:16:23 +0000
commit0c5ada685001731ad626f29f97d860a143f41553 (patch)
tree228d63e005b9fbaae948351337718c720217a62f /kde-base/kde-l10n
parentAdded the KDE 4.0.5 version of kcron. (diff)
downloadgentoo-2-0c5ada685001731ad626f29f97d860a143f41553.tar.gz
gentoo-2-0c5ada685001731ad626f29f97d860a143f41553.tar.bz2
gentoo-2-0c5ada685001731ad626f29f97d860a143f41553.zip
Added the KDE 4.0.5 version of kde-l10n.
(Portage version: 2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog8
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.0.5.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 7a8948467f54..976af80521e3 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.8 2008/05/15 22:58:52 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.9 2008/06/05 21:16:23 keytoaster Exp $
+
+*kde-l10n-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +kde-l10n-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of kde-l10n.
*kde-l10n-4.0.4 (15 May 2008)
diff --git a/kde-base/kde-l10n/kde-l10n-4.0.5.ebuild b/kde-base/kde-l10n/kde-l10n-4.0.5.ebuild
new file mode 100644
index 000000000000..a2b912b7a6e5
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.0.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.0.5.ebuild,v 1.1 2008/06/05 21:16:23 keytoaster Exp $
+
+EAPI="1"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gettext-0.15"
+RDEPEND=""
+
+LANGS="ar be bg ca cs csb da de el en_GB eo es et eu fa fi fr fy ga gl hi hu
+is it ja kk km ko lv mk nb nds ne nl nn pa pl pt pt_BR ru se sl sv th tr uk wa
+zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+ SRC_URI="${SRC_URI} linguas_${X}? ( ${URI_BASE}/${PN}-${X}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ if [[ -z ${A} ]]; then
+ echo
+ ewarn "You either have the LINGUAS variable unset, or it only"
+ ewarn "contains languages not supported by ${P}."
+ ewarn "You won't have any additional language support."
+ echo
+ ewarn "${P} supports these language codes:"
+ ewarn "${LANGS}"
+ echo
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # Create a top-level CMakeLists.txt to include the selected LINGUAS as sub-directories of ${S}
+ for dir in * ; do
+ [[ -d ${dir} ]] && echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ done
+}
+
+src_compile() {
+ if [[ -n ${A} ]]; then
+ kde4-base_src_compile
+ fi
+}
+
+src_install() {
+ if [[ -n ${A} ]]; then
+ kde4-base_src_install
+ fi
+}