summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-01 17:12:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-01 17:12:07 +0000
commita190313cdb8627227482c02a9f88a238127a1fa1 (patch)
tree715d12553f4607709f28d60718f8557f890e3a84 /kde-base/kcontrol
parentUpdate to new release. (diff)
downloadgentoo-2-a190313cdb8627227482c02a9f88a238127a1fa1.tar.gz
gentoo-2-a190313cdb8627227482c02a9f88a238127a1fa1.tar.bz2
gentoo-2-a190313cdb8627227482c02a9f88a238127a1fa1.zip
Update to new release.
(Portage version: 2.1_rc3-r3)
Diffstat (limited to 'kde-base/kcontrol')
-rw-r--r--kde-base/kcontrol/ChangeLog7
-rw-r--r--kde-base/kcontrol/files/digest-kcontrol-3.5.33
-rw-r--r--kde-base/kcontrol/kcontrol-3.5.3.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/kcontrol/ChangeLog b/kde-base/kcontrol/ChangeLog
index 63050ff8d6e0..26372dedbbc4 100644
--- a/kde-base/kcontrol/ChangeLog
+++ b/kde-base/kcontrol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcontrol
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.59 2006/06/01 07:11:07 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.60 2006/06/01 17:12:07 flameeyes Exp $
+
+*kcontrol-3.5.3 (01 Jun 2006)
+
+ 01 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> +kcontrol-3.5.3.ebuild:
+ Update to new release.
01 Jun 2006; Thomas Cort <tcort@gentoo.org> kcontrol-3.5.2.ebuild:
Stable on alpha wrt Bug #132213.
diff --git a/kde-base/kcontrol/files/digest-kcontrol-3.5.3 b/kde-base/kcontrol/files/digest-kcontrol-3.5.3
new file mode 100644
index 000000000000..f6eb5d9b686e
--- /dev/null
+++ b/kde-base/kcontrol/files/digest-kcontrol-3.5.3
@@ -0,0 +1,3 @@
+MD5 9cb6b8291c4f3f986e16f72129e8fcd0 kdebase-3.5.3.tar.bz2 23634194
+RMD160 ef55c72b97577dd86e5c64bf589ff9b2d556ec07 kdebase-3.5.3.tar.bz2 23634194
+SHA256 5a2b9bc5e2682684519dbae89b3bd73fbf5de1f1effd3ca072173a9638dc3ff8 kdebase-3.5.3.tar.bz2 23634194
diff --git a/kde-base/kcontrol/kcontrol-3.5.3.ebuild b/kde-base/kcontrol/kcontrol-3.5.3.ebuild
new file mode 100644
index 000000000000..7fd599386b6e
--- /dev/null
+++ b/kde-base/kcontrol/kcontrol-3.5.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.5.3.ebuild,v 1.1 2006/06/01 17:12:07 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Control Center"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl arts ieee1394 logitech-mouse opengl"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ ssl? ( dev-libs/openssl )
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ opengl? ( virtual/opengl )
+ ieee1394? ( sys-libs/libraw1394 )
+ logitech-mouse? ( >=dev-libs/libusb-0.1.10a )"
+
+RDEPEND="${DEPEND}
+ sys-apps/usbutils
+$(deprange $PV $MAXKDEVER kde-base/kcminit)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+$(deprange $PV $MAXKDEVER kde-base/kdesu)
+$(deprange $PV $MAXKDEVER kde-base/khelpcenter)
+$(deprange $PV $MAXKDEVER kde-base/khotkeys)
+$(deprange $PV $MAXKDEVER kde-base/libkonq)
+$(deprange $PV $MAXKDEVER kde-base/kicker)"
+
+KMEXTRACTONLY="kwin/kwinbindings.cpp
+ kicker/kicker/core/kickerbindings.cpp
+ kicker/taskbar/taskbarbindings.cpp
+ kdesktop/kdesktopbindings.cpp
+ klipper/klipperbindings.cpp
+ kxkb/kxkbbindings.cpp
+ kicker/taskmanager"
+
+KMEXTRA="doc/kinfocenter"
+KMCOMPILEONLY="kicker/libkicker
+ kicker/taskbar"
+KMCOPYLIB="libkonq libkonq
+ libkicker kicker/libkicker
+ libtaskbar kicker/taskbar
+ libtaskmanager kicker/taskmanager"
+
+src_compile() {
+ myconf="$myconf `use_with ssl` `use_with arts` `use_with opengl gl`
+ `use_with ieee1394 libraw1394` `use_with logitech-mouse libusb`
+ --with-usbids=/usr/share/misc/usb.ids"
+ kde-meta_src_compile
+}