summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-06-18 17:28:04 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-06-18 17:28:04 +0000
commit0b4e75fe6adeb1b91795ba7b7360e9760682e91b (patch)
tree2b552983e593e7358f7a46d70a271fde4f11c1cf /kde-base/kbabel
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-0b4e75fe6adeb1b91795ba7b7360e9760682e91b.tar.gz
gentoo-2-0b4e75fe6adeb1b91795ba7b7360e9760682e91b.tar.bz2
gentoo-2-0b4e75fe6adeb1b91795ba7b7360e9760682e91b.zip
Allow sys-libs/db-4* to satisfy kbabel's dependencies as all of them work fine. Removed the DEPEND on sys-devel/flex as it is a part of the official BASE system profile.
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'kde-base/kbabel')
-rw-r--r--kde-base/kbabel/ChangeLog7
-rw-r--r--kde-base/kbabel/kbabel-3.5.7.ebuild17
2 files changed, 11 insertions, 13 deletions
diff --git a/kde-base/kbabel/ChangeLog b/kde-base/kbabel/ChangeLog
index 466bd7c10315..31858f91d437 100644
--- a/kde-base/kbabel/ChangeLog
+++ b/kde-base/kbabel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kbabel
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/ChangeLog,v 1.56 2007/05/22 21:20:59 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/ChangeLog,v 1.57 2007/06/18 17:28:04 philantrop Exp $
+
+ 18 Jun 2007; Wulf C. Krueger <philantrop@gentoo.org> kbabel-3.5.7.ebuild:
+ Allow sys-libs/db-4* to satisfy kbabel's dependencies as all of them work
+ fine. Removed the DEPEND on sys-devel/flex as it is a part of the official
+ BASE system profile.
*kbabel-3.5.7 (22 May 2007)
diff --git a/kde-base/kbabel/kbabel-3.5.7.ebuild b/kde-base/kbabel/kbabel-3.5.7.ebuild
index 5e61af6ba1a0..88241a3074af 100644
--- a/kde-base/kbabel/kbabel-3.5.7.ebuild
+++ b/kde-base/kbabel/kbabel-3.5.7.ebuild
@@ -1,31 +1,24 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/kbabel-3.5.7.ebuild,v 1.1 2007/05/22 21:20:59 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/kbabel-3.5.7.ebuild,v 1.2 2007/06/18 17:28:04 philantrop Exp $
KMNAME=kdesdk
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
+inherit db-use kde-meta eutils
DESCRIPTION="KBabel - An advanced PO file editor"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="berkdb kdehiddenvisibility"
-DEPEND="sys-devel/flex
- berkdb? ( || ( =sys-libs/db-4.3*
- =sys-libs/db-4.2* ) )"
+DEPEND="berkdb? ( =sys-libs/db-4* )"
src_compile() {
local myconf=""
if use berkdb; then
- if has_version "=sys-libs/db-4.3*"; then
- myconf="${myconf} --with-berkeley-db --with-db-name=db-4.3
- --with-db-include-dir=/usr/include/db4.3"
- elif has_version "=sys-libs/db-4.2*"; then
- myconf="${myconf} --with-berkeley-db --with-db-name=db-4.2
- --with-db-include-dir=/usr/include/db4.2"
- fi
+ myconf="${myconf} --with-berkeley-db --with-db-lib="$(db_libname)"
+ --with-extra-includes=$(db_includedir)"
else
myconf="${myconf} --without-berkeley-db"
fi