summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-22 22:59:30 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-22 22:59:30 +0000
commitcbdb8c1c29b29ed923aef21dbed23184146e6eed (patch)
tree9693066e86e4ca24da2ac86ccaf985d7bec9df95 /kde-base/kalzium
parentPull in changes from overlay and patch for prefix support (Solaris) (diff)
downloadgentoo-2-cbdb8c1c29b29ed923aef21dbed23184146e6eed.tar.gz
gentoo-2-cbdb8c1c29b29ed923aef21dbed23184146e6eed.tar.bz2
gentoo-2-cbdb8c1c29b29ed923aef21dbed23184146e6eed.zip
Pull in changes from overlay and fix for prefix support (Solaris)
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog5
-rw-r--r--kde-base/kalzium/kalzium-4.3.4.ebuild17
2 files changed, 14 insertions, 8 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 49f5e8a5b429..9c3e8c9bfae1 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.152 2009/12/10 19:13:41 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.153 2009/12/22 22:59:30 abcd Exp $
+
+ 22 Dec 2009; Jonathan Callen <abcd@gentoo.org> kalzium-4.3.4.ebuild:
+ Pull in changes from overlay and fix for prefix support (Solaris)
10 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
-kalzium-4.3.1.ebuild:
diff --git a/kde-base/kalzium/kalzium-4.3.4.ebuild b/kde-base/kalzium/kalzium-4.3.4.ebuild
index a9ed34b86aeb..645d780d99f8 100644
--- a/kde-base/kalzium/kalzium-4.3.4.ebuild
+++ b/kde-base/kalzium/kalzium-4.3.4.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.3.4.ebuild,v 1.1 2009/12/01 10:01:27 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.3.4.ebuild,v 1.2 2009/12/22 22:59:30 abcd Exp $
EAPI="2"
KMNAME="kdeedu"
CPPUNIT_REQUIRED="optional"
OPENGL_REQUIRED="always"
-inherit kde4-meta
+inherit flag-o-matic kde4-meta
DESCRIPTION="KDE: periodic table of the elements."
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="editor debug +handbook +plasma solver"
-COMMON_DEPEND="
+RDEPEND="
$(add_kdebase_dep libkdeedu)
editor? ( >=sci-chemistry/openbabel-2.2 )
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
editor? ( >=dev-cpp/eigen-2.0.3:2 )
solver? ( dev-ml/facile[ocamlopt] )
"
-RDEPEND="${COMMON_DEPEND}"
KMEXTRACTONLY="
libkdeedu/kdeeduui/
@@ -29,12 +28,16 @@ KMEXTRACTONLY="
"
src_configure(){
- mycmakeargs="${mycmakeargs}
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
$(cmake-utils_use_with editor Eigen2)
$(cmake-utils_use_with editor OpenBabel2)
$(cmake-utils_use_with editor OpenGL)
$(cmake-utils_use_with solver OCaml)
- $(cmake-utils_use_with solver Libfacile)"
+ $(cmake-utils_use_with solver Libfacile)
+ )
kde4-meta_src_configure
}