summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-30 19:24:05 +0000
committerDror Levin <spatz@gentoo.org>2010-03-30 19:24:05 +0000
commit33f8e5751b7a1b957d43bdf346ff9f71b11ada25 (patch)
tree515cd40fbb798b2fb4c4b9546e7d34d1d8b9224d /kde-base/dolphin
parentVersion bump KDE 4.4.2 (diff)
downloadgentoo-2-33f8e5751b7a1b957d43bdf346ff9f71b11ada25.tar.gz
gentoo-2-33f8e5751b7a1b957d43bdf346ff9f71b11ada25.tar.bz2
gentoo-2-33f8e5751b7a1b957d43bdf346ff9f71b11ada25.zip
Version bump KDE 4.4.2
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.4.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index f49990f7c78f..ad397485aef6 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.68 2010/03/11 18:36:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.69 2010/03/30 19:24:05 spatz Exp $
+
+*dolphin-4.4.2 (30 Mar 2010)
+
+ 30 Mar 2010; Dror Levin <spatz@gentoo.org> +dolphin-4.4.2.ebuild:
+ Version bump
11 Mar 2010; Brent Baude <ranger@gentoo.org> dolphin-4.3.5.ebuild:
Marking dolphin-4.3.5 ppc stable for bug 300393
diff --git a/kde-base/dolphin/dolphin-4.4.2.ebuild b/kde-base/dolphin/dolphin-4.4.2.ebuild
new file mode 100644
index 000000000000..673adc689bd5
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.4.2.ebuild,v 1.1 2010/03/30 19:24:05 spatz Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook semantic-desktop subversion thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+ subversion? (
+ dev-util/subversion
+ $(add_kdebase_dep kompare)
+ )
+"
+PDEPEND="
+ thumbnail? ( $(add_kdebase_dep mplayerthumbs) )
+"
+
+KMLOADLIBS="libkonq"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use subversion; then
+ sed -e '/install(.*fileviewsvnplugin.*)/s/^/#DONOTINSTALL /g' \
+ -i dolphin/src/CMakeLists.txt || die 'failed to disable subversion plugin'
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}