summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 10:49:27 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 10:49:27 +0000
commitc6f723d1c31700594bc644b8ef3d77f718adefbb (patch)
treedeb1ef6a9a2579c03fa6bdd1b08b52f795cc0546 /kde-base/akonadi
parentDrop -Werror, now builds with gcc-4.4, bug #271611, thank hirakendu for report. (diff)
downloadgentoo-2-c6f723d1c31700594bc644b8ef3d77f718adefbb.tar.gz
gentoo-2-c6f723d1c31700594bc644b8ef3d77f718adefbb.tar.bz2
gentoo-2-c6f723d1c31700594bc644b8ef3d77f718adefbb.zip
Version bump KDE 4.2.4
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/akonadi')
-rw-r--r--kde-base/akonadi/ChangeLog7
-rw-r--r--kde-base/akonadi/akonadi-4.2.4.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index a66a70364595..f75e0e8309d0 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/akonadi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.22 2009/06/03 14:21:26 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.23 2009/06/04 10:49:26 alexxy Exp $
+
+*akonadi-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +akonadi-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -akonadi-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/akonadi/akonadi-4.2.4.ebuild b/kde-base/akonadi/akonadi-4.2.4.ebuild
new file mode 100644
index 000000000000..1bd2ae1738cc
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.2.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.2.4.ebuild,v 1.1 2009/06/04 10:49:27 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+# add when libmapi becomes available with an ebuild
+#exchange
+IUSE="debug +semantic-desktop"
+
+# add when libmapi becomes available with an ebuild
+#exchange? ( net-libs/libmapi )
+# not sure about libxml2... - reavertm
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop?]
+ >=kde-base/kdemaildir-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+ x11-misc/shared-mime-info
+"
+
+RDEPEND="${DEPEND}
+ >=app-office/akonadi-server-1.1[mysql]
+"
+
+KMEXTRACTONLY="
+ maildir/
+"
+
+src_prepare() {
+ if ! use semantic-desktop; then
+ sed -i -e "s/add_subdirectory( nepomuktag )//"\
+ akonadi/resources/CMakeLists.txt\
+ || die "Failed to disable nepomuktag"
+ fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ mycmakeargs="${mycmakeargs}
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR=/usr/share/dbus-1/services"
+ # replace with $(cmake-utils_use_with exchange OpenChange) when libmapi becomes available with an ebuild
+ mycmakeargs="${mycmakeargs}
+ -DWITH_LibXslt=ON
+ -DWITH_OpenChange=OFF
+ -DWITH_GNOKII=OFF
+ -DWITH_GLIB2=OFF
+ -DWITH_OpenSync=OFF
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mailserializerplugintest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/akonadi/plugins/tests/CMakeLists.txt || \
+ die "sed to disable mailserializerplugintest failed."
+
+ kde4-meta_src_test
+}