summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-05-18 14:57:53 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-05-18 14:57:53 +0000
commite517546b61b80e90747073ee2cbb4e5ed50950b0 (patch)
tree37fa294c57c67f397a413ed6dab099468c258a2b /gnustep-base
parentVersion bump, add icu USE-flag in sync with gnustep-base (diff)
downloadgentoo-2-e517546b61b80e90747073ee2cbb4e5ed50950b0.tar.gz
gentoo-2-e517546b61b80e90747073ee2cbb4e5ed50950b0.tar.bz2
gentoo-2-e517546b61b80e90747073ee2cbb4e5ed50950b0.zip
Version bump
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-back-xlib/ChangeLog10
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.24.1.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-back-xlib/ChangeLog b/gnustep-base/gnustep-back-xlib/ChangeLog
index c09b594c0ce3..d34e6a7a2b7c 100644
--- a/gnustep-base/gnustep-back-xlib/ChangeLog
+++ b/gnustep-base/gnustep-back-xlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-back-xlib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/ChangeLog,v 1.73 2014/12/27 19:28:10 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/ChangeLog,v 1.74 2015/05/18 14:57:53 voyageur Exp $
+
+*gnustep-back-xlib-0.24.1 (18 May 2015)
+
+ 18 May 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-back-xlib-0.24.1.ebuild:
+ Version bump
27 Dec 2014; Agostino Sarubbo <ago@gentoo.org>
gnustep-back-xlib-0.24.0.ebuild:
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.24.1.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.24.1.ebuild
new file mode 100644
index 000000000000..191031cb0730
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.24.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.24.1.ebuild,v 1.1 2015/05/18 14:57:53 voyageur Exp $
+
+EAPI=5
+inherit gnustep-base
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl xim"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ =gnustep-base/gnustep-gui-${PV%.*}*
+ opengl? ( virtual/opengl virtual/glu )
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ >=media-libs/freetype-2.1.9
+
+ !gnustep-base/gnustep-back-art
+ !gnustep-base/gnustep-back-cairo"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+src_configure() {
+ egnustep_env
+
+ myconf="$(use_enable opengl glx)"
+ myconf="$myconf $(use_enable xim)"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib"
+
+ econf $myconf
+}