summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-01-17 12:47:16 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-01-17 12:47:16 +0000
commitd31554f00edf52d0b9821d46492600bc6960fe90 (patch)
tree4916ea21e86077a6c1c7ae86bb032787832b1ea2 /gnustep-base
parentCorrect compilation against python on prefix (diff)
downloadgentoo-2-d31554f00edf52d0b9821d46492600bc6960fe90.tar.gz
gentoo-2-d31554f00edf52d0b9821d46492600bc6960fe90.tar.bz2
gentoo-2-d31554f00edf52d0b9821d46492600bc6960fe90.zip
Version bump
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog9
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.1.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index 014977044cf8..1632798bd4c0 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/libobjc2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.1 2010/10/13 15:16:41 voyageur Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.2 2011/01/17 12:47:16 voyageur Exp $
+
+*libobjc2-1.1 (17 Jan 2011)
+
+ 17 Jan 2011; Bernard Cafarelli <voyageur@gentoo.org> +libobjc2-1.1.ebuild:
+ Version bump
*libobjc2-1.0 (13 Oct 2010)
diff --git a/gnustep-base/libobjc2/libobjc2-1.1.ebuild b/gnustep-base/libobjc2/libobjc2-1.1.ebuild
new file mode 100644
index 000000000000..ff857c3ec47e
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.1.ebuild,v 1.1 2011/01/17 12:47:16 voyageur Exp $
+
+EAPI=3
+inherit multilib
+
+# We need gnustep-make, but gnustep-make can depend on libobjc
+# Use a temporary setup to install in /usr/
+GSMAKE=gnustep-make-2.4.0
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
+ ftp://ftp.gnustep.org/pub/gnustep/core/${GSMAKE}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND=""
+
+GSMAKE_S=${WORKDIR}/${GSMAKE}
+
+src_prepare() {
+ # Multilib-strict
+ cd "${GSMAKE_S}"
+ sed -e "s/lib/$(get_libdir)/g" \
+ -i FilesystemLayouts/fhs-system || die "multilib path sed failed"
+}
+
+src_configure() {
+ cd "${GSMAKE_S}"
+ econf --with-layout=fhs-system
+}
+
+src_compile() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" || die "compilation failed"
+}
+
+src_install() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
+ GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
+ GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+ DESTDIR="${D}" install || die "install has failed"
+}