summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-19 11:19:25 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-19 11:19:25 +0000
commit62bf77bfa1fc0b42d8d19a2ab22041e3b47ad460 (patch)
tree45fb645f46fdb3975e4b432a8f4ed3aaa31a8c5d /gnome-extra
parentBump to 3.0.0, from gnome overlay for GNOME 3 (diff)
downloadgentoo-2-62bf77bfa1fc0b42d8d19a2ab22041e3b47ad460.tar.gz
gentoo-2-62bf77bfa1fc0b42d8d19a2ab22041e3b47ad460.tar.bz2
gentoo-2-62bf77bfa1fc0b42d8d19a2ab22041e3b47ad460.zip
Bump to 2.0.0, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/at-spi/ChangeLog9
-rw-r--r--gnome-extra/at-spi/at-spi-1.32.0-r1.ebuild84
-rw-r--r--gnome-extra/at-spi/at-spi-2.0.0.ebuild22
3 files changed, 114 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index 8fb37f811b06..cf0e0ac55b9d 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.223 2011/04/14 19:48:20 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.224 2011/08/19 11:19:25 nirbheek Exp $
+
+*at-spi-2.0.0 (19 Aug 2011)
+*at-spi-1.32.0-r1 (19 Aug 2011)
+
+ 19 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +at-spi-1.32.0-r1.ebuild,
+ +at-spi-2.0.0.ebuild:
+ Bump to 2.0.0, from gnome overlay for GNOME 3
14 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> -at-spi-1.30.1.ebuild:
Clean up old revision.
diff --git a/gnome-extra/at-spi/at-spi-1.32.0-r1.ebuild b/gnome-extra/at-spi/at-spi-1.32.0-r1.ebuild
new file mode 100644
index 000000000000..15c455e8c918
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.32.0-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.32.0-r1.ebuild,v 1.1 2011/08/19 11:19:25 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+
+inherit gnome2 python
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.29.2
+ >=x11-libs/gtk+-2.19.7:2
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+# needs a live properly configured environment. Not really suited to
+# an ebuild restricted environment
+RESTRICT="test"
+
+pkg_setup() {
+ # relocate must be explicitely set
+ G2CONF="${G2CONF}
+ --enable-sm
+ --enable-relocate
+ --disable-xevie"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${ED}"/usr/$(get_libdir)/orbit-2.0 -name "*.la" -delete
+ find "${ED}"/usr/$(get_libdir)/gtk-2.0 -name "*.la" -delete
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize pyatspi_corba
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup pyatspi_corba
+}
diff --git a/gnome-extra/at-spi/at-spi-2.0.0.ebuild b/gnome-extra/at-spi/at-spi-2.0.0.ebuild
new file mode 100644
index 000000000000..e491223b4591
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-2.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-2.0.0.ebuild,v 1.1 2011/08/19 11:19:25 nirbheek Exp $
+
+EAPI="3"
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+SRC_URI=""
+
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-atk-${PV}:2
+ >=app-accessibility/at-spi2-core-${PV}:2
+ >=dev-python/pyatspi-${PV}
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND=""