summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-04 11:15:20 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-04 11:15:20 +0000
commit265b9b26d3d04e8f45495d5889e87a11278c04ff (patch)
tree1987671067f7134334d41cc0b8aa33d0f553fc06 /gnome-extra/libgda
parentx86 stable wrt bug #347115 (diff)
downloadgentoo-2-265b9b26d3d04e8f45495d5889e87a11278c04ff.tar.gz
gentoo-2-265b9b26d3d04e8f45495d5889e87a11278c04ff.tar.bz2
gentoo-2-265b9b26d3d04e8f45495d5889e87a11278c04ff.zip
Version bump with bugfixes and translation updates, removes old DB providers.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog8
-rw-r--r--gnome-extra/libgda/files/libgda-4.2.2-fix-build-order.patch20
-rw-r--r--gnome-extra/libgda/libgda-4.2.2.ebuild121
3 files changed, 148 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index cb2d7cb12240..99da5660640e 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/libgda
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.153 2010/11/01 12:18:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.154 2010/12/04 11:15:20 pacho Exp $
+
+*libgda-4.2.2 (04 Dec 2010)
+
+ 04 Dec 2010; Pacho Ramos <pacho@gentoo.org> +libgda-4.2.2.ebuild,
+ +files/libgda-4.2.2-fix-build-order.patch:
+ Version bump with bugfixes and translation updates, removes old DB providers.
01 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org> -libgda-4.1.0.ebuild,
libgda-4.2.0.ebuild:
diff --git a/gnome-extra/libgda/files/libgda-4.2.2-fix-build-order.patch b/gnome-extra/libgda/files/libgda-4.2.2-fix-build-order.patch
new file mode 100644
index 000000000000..ac310890cdb0
--- /dev/null
+++ b/gnome-extra/libgda/files/libgda-4.2.2-fix-build-order.patch
@@ -0,0 +1,20 @@
+--- libgda/sqlite/Makefile.am.orig 2010-12-04 11:33:12.000000000 +0100
++++ libgda/sqlite/Makefile.am 2010-12-04 11:34:50.000000000 +0100
+@@ -58,9 +58,9 @@
+ gda-sqlite.h \
+ keywords_hash.h \
+ gda-symbols-util.h \
+- gda-symbols-util.c
+-
+-BUILT_SOURCES = xml_embedded.h keywords_hash.c
++ gda-symbols-util.c \
++ xml_embedded.h \
++ keywords_hash.c
+
+ libgda_sqlite_la_SOURCES = $(sqlitesources)
+ libgda_sqlite_la_CFLAGS = -DPNAME=\""SQLite"\" -DCLASS_PREFIX=\""GdaSqlite"\" -DSEARCH_LIB_PATH=\""$(SQLITE_PATH)"\"
+@@ -86,3 +86,4 @@
+ EXTRA_DIST = gen_emb_string.c mkkeywordhash.c keywords.list
+
+ CLEANFILES = gen_emb_string$(EXEEXT_FOR_BUILD) mkkeywordhash$(EXEEXT_FOR_BUILD) $(BUILT_SOURCES)
++BUILT_SOURCES = xml_embedded.h keywords_hash.c
diff --git a/gnome-extra/libgda/libgda-4.2.2.ebuild b/gnome-extra/libgda/libgda-4.2.2.ebuild
new file mode 100644
index 000000000000..2db515b6a46c
--- /dev/null
+++ b/gnome-extra/libgda/libgda-4.2.2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-4.2.2.ebuild,v 1.1 2010/12/04 11:15:20 pacho Exp $
+
+EAPI="3"
+
+inherit autotools db-use eutils flag-o-matic gnome2 java-pkg-opt-2
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+LICENSE="GPL-2 LGPL-2"
+
+# MDB support currently works with CVS only, so disable it in the meantime
+IUSE="berkdb bindist canvas doc firebird gnome-keyring gtk graphviz http +introspection json mysql oci8 postgres sourceview ssl"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# FIXME: sqlite is automagic, but maybe it is a hard-dep
+# FIXME: autoconf is a hell of inconsistencies
+RDEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2
+ dev-libs/libxslt
+ dev-libs/libunique
+ sys-libs/readline
+ sys-libs/ncurses
+ berkdb? ( sys-libs/db )
+ !bindist? ( firebird? ( dev-db/firebird ) )
+ gtk? (
+ >=x11-libs/gtk+-2.12
+ canvas? ( x11-libs/goocanvas )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ graphviz? ( media-gfx/graphviz )
+ )
+ gnome-keyring? ( || ( gnome-base/libgnome-keyring <gnome-base/gnome-keyring-2.29.4 ) )
+ http? ( >=net-libs/libsoup-2.24:2.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.5 )
+ json? ( dev-libs/json-glib )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ ssl? ( dev-libs/openssl )
+ >=dev-db/sqlite-3.6.22:3"
+# mdb? ( >app-office/mdbtools-0.5 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.35.5
+ >=app-text/gnome-doc-utils-0.9
+ >=dev-util/gtk-doc-am-1
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+# Tests are not really good
+RESTRICT="test"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+
+ if use canvas || use graphviz || use sourceview; then
+ if ! use gtk; then
+ ewarn "You must enable USE=gtk to make use of canvas, graphivz or sourceview USE flag."
+ ewarn "Disabling for now."
+ G2CONF="${G2CONF} --without-goocanvas --without-graphivz --without-gtksourceview"
+ else
+ G2CONF="${G2CONF}
+ $(use_with canvas goocanvas)
+ $(use_with graphviz)
+ $(use_with sourceview gtksourceview)"
+ fi
+ fi
+
+ G2CONF="${G2CONF}
+ --with-unique
+ --disable-scrollkeeper
+ --disable-static
+ --enable-system-sqlite
+ $(use_with berkdb bdb /usr)
+ $(use_with gnome-keyring)
+ $(use_with gtk ui)
+ $(use_with http libsoup)
+ $(use_enable introspection)
+ $(use_with java java $JAVA_HOME)
+ $(use_with mysql mysql /usr)
+ $(use_with postgres postgres /usr)
+ $(use_enable ssl crypto)
+ --without-mdb"
+# $(use_with mdb mdb /usr)
+
+ if use bindist; then
+ # firebird license is not GPL compatible
+ G2CONF="${G2CONF} --without-firebird"
+ else
+ G2CONF="${G2CONF} $(use_with firebird firebird /usr)"
+ fi
+
+ use berkdb && append-cppflags "-I$(db_includedir)"
+ # --disable-json doesn't work, upstream bug #636439
+ use json && G2CONF="${G2CONF} --enable-json"
+ use oci8 || G2CONF="${G2CONF} --without-oracle"
+
+ # Not in portage
+ G2CONF="${G2CONF}
+ --disable-default-binary"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix build order for generated content, upstream #630958
+ epatch "${FILESDIR}/${PN}-4.2.2-fix-build-order.patch"
+
+ # Fix compilation failure of keyword_hash.c, upstream #630959
+ epatch "${FILESDIR}/${PN}-4.2.0-missing-include-in-keyword_hash-generator.patch"
+
+ intltoolize --force --copy --automake || die
+ eautoreconf
+}
+
+src_test() {
+ emake check HOME=$(unset HOME; echo "~") || die "tests failed"
+}