summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-31 16:40:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-31 16:40:34 +0000
commitd681246b41237f557e896bec7e846e3305c3c098 (patch)
treee83ad9bcfc5afe2da28c3b3cc47f5b5fec7f63c7 /gnome-extra/gtkhtml
parentVersion bump. Respect LDFLAGS, #246016, thank Olivier Huber. Probably fixes c... (diff)
downloadgentoo-2-d681246b41237f557e896bec7e846e3305c3c098.tar.gz
gentoo-2-d681246b41237f557e896bec7e846e3305c3c098.tar.bz2
gentoo-2-d681246b41237f557e896bec7e846e3305c3c098.zip
Bump to 3.24.4. Bug fixes.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog8
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.24.4.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index f9889062f2a5..270f12f4f59c 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.171 2009/01/26 21:54:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.172 2009/01/31 16:40:34 eva Exp $
+
+*gtkhtml-3.24.4 (31 Jan 2009)
+
+ 31 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkhtml-3.24.4.ebuild:
+ Bump to 3.24.4. Bug fixes.
*gtkhtml-3.24.3 (26 Jan 2009)
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.24.4.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.24.4.ebuild
new file mode 100644
index 000000000000..6d7a710835cc
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.24.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.24.4.ebuild,v 1.1 2009/01/31 16:40:34 eva Exp $
+
+EAPI="1"
+
+inherit autotools gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# We keep bonobo until we can make sure no apps in tree uses
+# the old composer code.
+# We could probably enable the glade catalog installation with
+# USE="glade" if someone requests it
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=gnome-base/gail-1.1
+ >=x11-themes/gnome-icon-theme-1.2
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libbonoboui-2.2.4
+ >=gnome-base/orbit-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ app-text/enchant
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ net-libs/libsoup:2.4"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="--disable-static --with-bonobo-editor"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix deprecated API disabling in used glib library - this is not future-proof, bug 210657
+ sed -i -e '/G_DISABLE_DEPRECATED/d' \
+ "${S}/gtkhtml/Makefile.am" "${S}/gtkhtml/Makefile.in" \
+ "${S}/components/html-editor/Makefile.am" "${S}/components/html-editor/Makefile.in"
+
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ "${S}/a11y/Makefile.am" "${S}/a11y/Makefile.in"
+
+ # For some reason, won't install translations otherwise.
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautomake
+}