summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-13 10:07:08 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-13 10:07:08 +0000
commitc6bcc7c6ac69cb78c89b1e300d4e273ec0bd250b (patch)
tree56135f247f9aee275ef11a0f071df415f9309663 /gnome-base
parentPrepend doc path with EPREFIX (diff)
downloadgentoo-2-c6bcc7c6ac69cb78c89b1e300d4e273ec0bd250b.tar.gz
gentoo-2-c6bcc7c6ac69cb78c89b1e300d4e273ec0bd250b.tar.bz2
gentoo-2-c6bcc7c6ac69cb78c89b1e300d4e273ec0bd250b.zip
Depend on accountsservice[introspection] (bug #390361, thanks to Cesko Voeten <cvoeten@gmail.com> for reporting).
Also, drop old 3.0 version. (Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-shell/ChangeLog11
-rw-r--r--gnome-base/gnome-shell/files/gnome-shell-3.0.2-unbreak-extension-css.patch93
-rw-r--r--gnome-base/gnome-shell/files/gnome-shell-3.0.2-user-removed-signals.patch33
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.0.2-r1.ebuild129
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild4
-rw-r--r--gnome-base/gnome-shell/metadata.xml7
6 files changed, 13 insertions, 264 deletions
diff --git a/gnome-base/gnome-shell/ChangeLog b/gnome-base/gnome-shell/ChangeLog
index ccce8ae2e214..66dcb99ab84f 100644
--- a/gnome-base/gnome-shell/ChangeLog
+++ b/gnome-base/gnome-shell/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/gnome-shell
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/ChangeLog,v 1.3 2011/11/05 07:51:56 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/ChangeLog,v 1.4 2011/11/13 10:07:07 tetromino Exp $
+
+ 13 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -gnome-shell-3.0.2-r1.ebuild,
+ -files/gnome-shell-3.0.2-unbreak-extension-css.patch,
+ -files/gnome-shell-3.0.2-user-removed-signals.patch,
+ gnome-shell-3.2.1-r1.ebuild, metadata.xml:
+ Depend on accountsservice[introspection] (bug #390361, thanks to Cesko Voeten
+ <cvoeten@gmail.com> for reporting).
+ Also, drop old 3.0 version.
*gnome-shell-3.2.1-r1 (05 Nov 2011)
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.0.2-unbreak-extension-css.patch b/gnome-base/gnome-shell/files/gnome-shell-3.0.2-unbreak-extension-css.patch
deleted file mode 100644
index 75c6aee62d62..000000000000
--- a/gnome-base/gnome-shell/files/gnome-shell-3.0.2-unbreak-extension-css.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 2674d96e547b27ed5c377804c1059bdfd926086e Mon Sep 17 00:00:00 2001
-From: Giovanni Campagna <gcampagna@src.gnome.org>
-Date: Thu, 02 Jun 2011 15:05:08 +0000
-Subject: StTheme: retrive the list of custom stylesheets and use it in loadTheme()
-
-Using the list of stylesheets loaded with st_theme_load_stylesheet(),
-one can build an StTheme that is completely identical to the previous
-one, except for one property (application-stylesheet).
-This allows rt and the user-theme extension to work while respecting
-the theming of other extensions.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=650971
----
-diff --git a/js/ui/main.js b/js/ui/main.js
-index 1d27b4c..c0f4845 100644
---- a/js/ui/main.js
-+++ b/js/ui/main.js
-@@ -393,12 +393,21 @@ function setThemeStylesheet(cssStylesheet)
- */
- function loadTheme() {
- let themeContext = St.ThemeContext.get_for_stage (global.stage);
-+ let previousTheme = themeContext.get_theme();
-
- let cssStylesheet = _defaultCssStylesheet;
- if (_cssStylesheet != null)
- cssStylesheet = _cssStylesheet;
-
- let theme = new St.Theme ({ application_stylesheet: cssStylesheet });
-+
-+ if (previousTheme) {
-+ let customStylesheets = previousTheme.get_custom_stylesheets();
-+
-+ for (let i = 0; i < customStylesheets.length; i++)
-+ theme.load_stylesheet(customStylesheets[i]);
-+ }
-+
- themeContext.set_theme (theme);
- }
-
-diff --git a/src/st/st-theme.c b/src/st/st-theme.c
-index 326d9de..2058e32 100644
---- a/src/st/st-theme.c
-+++ b/src/st/st-theme.c
-@@ -256,6 +256,30 @@ st_theme_unload_stylesheet (StTheme *theme,
- cr_stylesheet_unref (stylesheet);
- }
-
-+/**
-+ * st_theme_get_custom_stylesheets:
-+ * @theme: an #StTheme
-+ *
-+ * Returns: (transfer full) (element-type utf8): the list of stylesheet filenames
-+ * that were loaded with st_theme_load_stylesheet()
-+ */
-+GSList*
-+st_theme_get_custom_stylesheets (StTheme *theme)
-+{
-+ GSList *result = NULL;
-+ GSList *iter;
-+
-+ for (iter = theme->custom_stylesheets; iter; iter = iter->next)
-+ {
-+ CRStyleSheet *stylesheet = iter->data;
-+ gchar *filename = g_hash_table_lookup (theme->filenames_by_stylesheet, stylesheet);
-+
-+ result = g_slist_prepend (result, g_strdup (filename));
-+ }
-+
-+ return result;
-+}
-+
- static GObject *
- st_theme_constructor (GType type,
- guint n_construct_properties,
-diff --git a/src/st/st-theme.h b/src/st/st-theme.h
-index 003c2a7..0a044bf 100644
---- a/src/st/st-theme.h
-+++ b/src/st/st-theme.h
-@@ -51,9 +51,9 @@ StTheme *st_theme_new (const char *application_stylesheet,
- const char *theme_stylesheet,
- const char *default_stylesheet);
-
--gboolean st_theme_load_stylesheet (StTheme *theme, const char *path, GError **error);
--
--void st_theme_unload_stylesheet (StTheme *theme, const char *path);
-+gboolean st_theme_load_stylesheet (StTheme *theme, const char *path, GError **error);
-+void st_theme_unload_stylesheet (StTheme *theme, const char *path);
-+GSList *st_theme_get_custom_stylesheets (StTheme *theme);
-
- G_END_DECLS
-
---
-cgit v0.9.0.2
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.0.2-user-removed-signals.patch b/gnome-base/gnome-shell/files/gnome-shell-3.0.2-user-removed-signals.patch
deleted file mode 100644
index adae1f0cb5b9..000000000000
--- a/gnome-base/gnome-shell/files/gnome-shell-3.0.2-user-removed-signals.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 9a7f3dbd2030a5e1b54297f1aa7cf228eccafb27 Mon Sep 17 00:00:00 2001
-From: Ray Strode <rstrode@redhat.com>
-Date: Tue, 24 May 2011 22:15:10 -0400
-Subject: [PATCH] gdm: ignore user-removed signals for untracked users
-
-If we don't know about a user, we don't care if it goes away,
-and we shouldn't try to remove it from the book keeping.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=647893
----
- src/gdmuser/gdm-user-manager.c | 7 +++++++
- 1 files changed, 7 insertions(+), 0 deletions(-)
-
-diff --git a/src/gdmuser/gdm-user-manager.c b/src/gdmuser/gdm-user-manager.c
-index e7ca833..561be32 100644
---- a/src/gdmuser/gdm-user-manager.c
-+++ b/src/gdmuser/gdm-user-manager.c
-@@ -887,6 +887,13 @@ on_user_removed_in_accounts_service (DBusGProxy *proxy,
-
- user = g_hash_table_lookup (manager->priv->users_by_object_path, object_path);
-
-+ if (user == NULL) {
-+ g_debug ("GdmUserManager: ignoring untracked user %s", object_path);
-+ return;
-+ } else {
-+ g_debug ("GdmUserManager: tracked user %s removed from accounts service", object_path);
-+ }
-+
- manager->priv->new_users = g_slist_remove (manager->priv->new_users, user);
-
- remove_user (manager, user);
---
-1.7.5.1 \ No newline at end of file
diff --git a/gnome-base/gnome-shell/gnome-shell-3.0.2-r1.ebuild b/gnome-base/gnome-shell/gnome-shell-3.0.2-r1.ebuild
deleted file mode 100644
index e2d1c67fdde2..000000000000
--- a/gnome-base/gnome-shell/gnome-shell-3.0.2-r1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.0.2-r1.ebuild,v 1.2 2011/10/21 02:22:11 tetromino Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="2:2.5"
-
-inherit eutils gnome2 python
-
-DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
-HOMEPAGE="http://live.gnome.org/GnomeShell"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+nm-applet"
-KEYWORDS="~amd64 ~x86"
-
-# gnome-desktop-2.91.2 is needed due to header changes, db82a33 in gnome-desktop
-# FIXME: Automagic gnome-bluetooth[introspection] support.
-# latest gsettings-desktop-schemas is needed due to commit 602fa1c6
-# latest g-c-c is needed due to https://bugs.gentoo.org/show_bug.cgi?id=360057
-# libXfixes-5.0 needed for pointer barriers
-COMMON_DEPEND=">=dev-libs/glib-2.25.9:2
- >=dev-libs/gjs-0.7.11
- >=dev-libs/gobject-introspection-0.10.1
- x11-libs/gdk-pixbuf:2[introspection]
- >=x11-libs/gtk+-3.0.0:3[introspection]
- >=media-libs/clutter-1.5.15:1.0[introspection]
- >=gnome-base/gnome-desktop-2.91.2:3
- >=gnome-base/gsettings-desktop-schemas-2.91.91
- >=gnome-extra/evolution-data-server-2.32.0
- >=media-libs/gstreamer-0.10.16:0.10
- >=media-libs/gst-plugins-base-0.10.16:0.10
- >=net-im/telepathy-logger-0.2.4[introspection]
- >=net-libs/telepathy-glib-0.13.12[introspection]
- >=net-wireless/gnome-bluetooth-2.90.0[introspection]
- >=sys-auth/polkit-0.100[introspection]
- >=x11-wm/mutter-3.0.0[introspection]
-
- dev-libs/dbus-glib
- dev-libs/libxml2:2
- x11-libs/pango[introspection]
- dev-libs/libcroco:0.6
-
- gnome-base/gconf:2[introspection]
- gnome-base/gnome-menus
- gnome-base/librsvg
- media-libs/libcanberra
- media-sound/pulseaudio
-
- x11-libs/startup-notification
- x11-libs/libX11
- >=x11-libs/libXfixes-5.0
- x11-apps/mesa-progs"
-# Runtime-only deps are probably incomplete and approximate.
-# Each block:
-# 1. Pull in polkit-0.101 for pretty authorization dialogs
-# 2. Introspection stuff + dconf needed via imports.gi.*
-# 3. gnome-session is needed for gnome-session-quit
-# 4. Control shell settings
-# 5. accountsservice is needed for GdmUserManager
-# 6. nm-applet is needed for auth prompting and the wireless connection dialog
-RDEPEND="${COMMON_DEPEND}
- >=sys-auth/polkit-0.101[introspection]
-
- >=gnome-base/dconf-0.4.1
- >=gnome-base/libgnomekbd-2.91.4[introspection]
- sys-power/upower[introspection]
-
- >=gnome-base/gnome-session-2.91.91
-
- >=gnome-base/gnome-settings-daemon-2.91
- >=gnome-base/gnome-control-center-2.91.92-r1
-
- >=sys-apps/accountsservice-0.6.12
-
- nm-applet? (
- >=gnome-extra/nm-applet-0.8.999
- >=net-misc/networkmanager-0.8.999[introspection] )"
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
- >=dev-util/pkgconfig-0.22
- >=dev-util/intltool-0.26
- gnome-base/gnome-common
- !!=dev-lang/spidermonkey-1.8.2*"
-# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
-# https://bugs.gentoo.org/show_bug.cgi?id=360413
-
-pkg_setup() {
- DOCS="AUTHORS README"
- # Don't error out on warnings
- G2CONF="${G2CONF}
- --enable-compile-warnings=maximum
- --disable-schemas-compile
- --disable-jhbuild-wrapper-script"
-}
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=647893
- # can trigger the crash even with accountsservice-0.6.12
- epatch "${FILESDIR}/${PN}-3.0.2-user-removed-signals.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=650971
- # Don't clobber extensions' styles
- epatch "${FILESDIR}/${PN}-3.0.2-unbreak-extension-css.patch"
- gnome2_src_prepare
-
- # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
- # Note: sed Makefile.in because it is generated from several Makefile.ams
- sed -e 's/-DG_DISABLE_DEPRECATED//g' -i src/Makefile.in || die "sed failed"
-}
-
-src_install() {
- gnome2_src_install
- python_convert_shebangs 2 "${D}"/usr/bin/gnome-shell-extension-tool
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if ! has_version '>=media-libs/gst-plugins-good-0.10.23' || \
- ! has_version 'media-plugins/gst-plugins-vp8'; then
- ewarn "To make use of GNOME Shell's built-in screen recording utility,"
- ewarn "you need to either install >=media-libs/gst-plugins-good-0.10.23"
- ewarn "and media-plugins/gst-plugins-vp8, or use dconf-editor to change"
- ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
- fi
-}
diff --git a/gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild b/gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild
index 5ae58635cc8e..8d21de31241b 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild,v 1.1 2011/11/05 07:51:56 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.2.1-r1.ebuild,v 1.2 2011/11/13 10:07:07 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -81,7 +81,7 @@ RDEPEND="${COMMON_DEPEND}
>=gnome-base/gnome-settings-daemon-2.91
>=gnome-base/gnome-control-center-2.91.92-r1
- >=sys-apps/accountsservice-0.6.14
+ >=sys-apps/accountsservice-0.6.14[introspection]
>=app-accessibility/caribou-0.3"
DEPEND="${COMMON_DEPEND}
diff --git a/gnome-base/gnome-shell/metadata.xml b/gnome-base/gnome-shell/metadata.xml
index 03af788d5366..da6fd63d0085 100644
--- a/gnome-base/gnome-shell/metadata.xml
+++ b/gnome-base/gnome-shell/metadata.xml
@@ -1,10 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>gnome</herd>
- <use>
- <flag name="nm-applet">Pull in an automagic dependency on
- <pkg>gnome-extra/nm-applet</pkg> and
- <pkg>net-misc/networkmanager</pkg>, should be removed soon</flag>
- </use>
+<herd>gnome</herd>
</pkgmetadata>