summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-05 16:41:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-05 16:41:25 +0000
commitb1bf328eb2906987d202cb405f434e67f3ff9e1f (patch)
tree3555d536443fa4835b8f2587220c91aebae36e59 /gnome-base
parentUpdate, thanx sebastian (diff)
downloadgentoo-2-b1bf328eb2906987d202cb405f434e67f3ff9e1f.tar.gz
gentoo-2-b1bf328eb2906987d202cb405f434e67f3ff9e1f.tar.bz2
gentoo-2-b1bf328eb2906987d202cb405f434e67f3ff9e1f.zip
Update
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.2.ebuild45
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.21
2 files changed, 46 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.2.ebuild b/gnome-base/bonobo/bonobo-1.0.2.ebuild
new file mode 100644
index 000000000000..e684df29b838
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.2.ebuild,v 1.1 2001/05/05 16:41:25 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/oaf-0.6.4
+ >=gnome-base/gnome-print-0.25"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ # on of the samples in the package need to be regenerated from the idl files
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo.h
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo-*.c
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.2 b/gnome-base/bonobo/files/digest-bonobo-1.0.2
new file mode 100644
index 000000000000..3e7719bf5b0d
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.2
@@ -0,0 +1 @@
+MD5 950e76b5b916739e1701b0db533782ce bonobo-1.0.2.tar.gz