summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-08-19 08:28:51 +0000
committerMart Raudsepp <leio@gentoo.org>2008-08-19 08:28:51 +0000
commit74f251635f598e99faa1a317337ecd2025f464e3 (patch)
tree4c9a8c81e539f05a929b1786eb6399185485bbde /gnome-base
parentVersion bump to fix invalid chunk type problem, bug #234916. Removed affected... (diff)
downloadgentoo-2-74f251635f598e99faa1a317337ecd2025f464e3.tar.gz
gentoo-2-74f251635f598e99faa1a317337ecd2025f464e3.tar.bz2
gentoo-2-74f251635f598e99faa1a317337ecd2025f464e3.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libglade/ChangeLog7
-rw-r--r--gnome-base/libglade/libglade-2.6.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/gnome-base/libglade/ChangeLog b/gnome-base/libglade/ChangeLog
index 3d30d642dd42..9c92fb9917b4 100644
--- a/gnome-base/libglade/ChangeLog
+++ b/gnome-base/libglade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/libglade
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.113 2008/03/31 04:59:16 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.114 2008/08/19 08:28:51 leio Exp $
+
+*libglade-2.6.3 (19 Aug 2008)
+
+ 19 Aug 2008; Mart Raudsepp <leio@gentoo.org> +libglade-2.6.3.ebuild:
+ Version bump
31 Mar 2008; <ricmm@gentoo.org> libglade-2.6.1.ebuild,
libglade-2.6.2.ebuild:
diff --git a/gnome-base/libglade/libglade-2.6.3.ebuild b/gnome-base/libglade/libglade-2.6.3.ebuild
new file mode 100644
index 000000000000..b73e4d72f77c
--- /dev/null
+++ b/gnome-base/libglade/libglade-2.6.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.6.3.ebuild,v 1.1 2008/08/19 08:28:51 leio Exp $
+
+# FIXME : catalog stuff
+inherit eutils gnome2
+
+DESCRIPTION="Library to construct graphical interfaces at runtime"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.10
+ >=dev-libs/atk-1.9
+ >=dev-libs/libxml2-2.4.10
+ >=dev-lang/python-2.0-r7"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_compile() {
+ # patch to stop make install installing the xml catalog
+ # because we do it ourselves in postinst()
+ epatch "${FILESDIR}"/Makefile.in.am-2.4.2-xmlcatalog.patch
+
+ gnome2_src_compile
+}
+
+src_install() {
+ dodir /etc/xml
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ echo ">>> Updating XML catalog"
+ /usr/bin/xmlcatalog --noout --add "system" \
+ "http://glade.gnome.org/glade-2.0.dtd" \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ echo ">>> removing entries from the XML catalog"
+ /usr/bin/xmlcatalog --noout --del \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+}