summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-02 22:36:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-02 22:36:31 +0000
commit4bb8c35b76b6773013a67e4a5380567474984693 (patch)
treeda634925dee2c4c44753fa0ac517a2f3791b264a /gnome-base
parentAdd gnome-base/gvfs-1.0.3-r11 to bluez-4 mask. (diff)
downloadgentoo-2-4bb8c35b76b6773013a67e4a5380567474984693.tar.gz
gentoo-2-4bb8c35b76b6773013a67e4a5380567474984693.tar.bz2
gentoo-2-4bb8c35b76b6773013a67e4a5380567474984693.zip
Fix http leak, bug #256892. Fix obexftp icon, bug #256890.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gvfs/ChangeLog10
-rw-r--r--gnome-base/gvfs/files/gvfs-1.0.3-http-leak.patch57
-rw-r--r--gnome-base/gvfs/files/gvfs-1.0.3-obexftp-icon.patch22
-rw-r--r--gnome-base/gvfs/gvfs-1.0.3-r1.ebuild90
-rw-r--r--gnome-base/gvfs/gvfs-1.0.3-r11.ebuild93
5 files changed, 271 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index cd93b81af626..48db279fd250 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.46 2009/01/30 18:52:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.47 2009/02/02 22:36:31 eva Exp $
+
+*gvfs-1.0.3-r11 (02 Feb 2009)
+*gvfs-1.0.3-r1 (02 Feb 2009)
+
+ 02 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gvfs-1.0.3-http-leak.patch, +files/gvfs-1.0.3-obexftp-icon.patch,
+ +gvfs-1.0.3-r1.ebuild, +gvfs-1.0.3-r11.ebuild:
+ Fix http leak, bug #256892. Fix obexftp icon, bug #256890.
30 Jan 2009; Alexis Ballier <aballier@gentoo.org> gvfs-1.0.3.ebuild,
gvfs-1.0.3-r10.ebuild:
diff --git a/gnome-base/gvfs/files/gvfs-1.0.3-http-leak.patch b/gnome-base/gvfs/files/gvfs-1.0.3-http-leak.patch
new file mode 100644
index 000000000000..93adf5b043ac
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.0.3-http-leak.patch
@@ -0,0 +1,57 @@
+Index: daemon/gvfsbackendhttp.c
+===================================================================
+--- daemon/gvfsbackendhttp.c (revision 2129)
++++ daemon/gvfsbackendhttp.c (revision 2130)
+@@ -346,6 +346,7 @@
+ error->message);
+
+ g_error_free (error);
++ g_object_unref (stream);
+ return;
+ }
+
+@@ -371,6 +372,8 @@
+ msg = soup_message_new_from_uri (SOUP_METHOD_GET, uri);
+ soup_uri_free (uri);
+
++ soup_message_body_set_accumulate (msg->response_body, FALSE);
++
+ stream = soup_input_stream_new (op_backend->session_async, msg);
+ g_object_unref (msg);
+
+Index: daemon/soup-input-stream.c
+===================================================================
+--- daemon/soup-input-stream.c (revision 2129)
++++ daemon/soup-input-stream.c (revision 2130)
+@@ -714,6 +714,7 @@
+ soup_input_stream_done_io (stream);
+
+ g_simple_async_result_complete (result);
++ g_object_unref (result);
+ }
+
+ static void
+@@ -748,6 +749,7 @@
+ {
+ g_simple_async_result_set_op_res_gssize (result, 0);
+ g_simple_async_result_complete_in_idle (result);
++ g_object_unref (result);
+ return;
+ }
+
+@@ -756,6 +758,7 @@
+ gsize nread = read_from_leftover (priv, buffer, count);
+ g_simple_async_result_set_op_res_gssize (result, nread);
+ g_simple_async_result_complete_in_idle (result);
++ g_object_unref (result);
+ return;
+ }
+
+@@ -804,6 +807,7 @@
+ }
+
+ g_simple_async_result_complete_in_idle (result);
++ g_object_unref (result);
+ }
+
+ static gboolean
diff --git a/gnome-base/gvfs/files/gvfs-1.0.3-obexftp-icon.patch b/gnome-base/gvfs/files/gvfs-1.0.3-obexftp-icon.patch
new file mode 100644
index 000000000000..6ae45e9d4004
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.0.3-obexftp-icon.patch
@@ -0,0 +1,22 @@
+# https://bugs.gentoo.org/show_bug.cgi?id=256890
+# https://bugzilla.gnome.org/show_bug.cgi?id=542687
+Index: b/daemon/gvfsbackendobexftp.c
+===================================================================
+--- a/daemon/gvfsbackendobexftp.c (revision 2125)
++++ b/daemon/gvfsbackendobexftp.c (working copy)
+@@ -376,7 +376,14 @@
+ g_file_info_set_file_type (info, G_FILE_TYPE_DIRECTORY);
+ g_file_info_set_content_type (info, "inode/directory");
+ g_file_info_set_name (info, "/");
+- g_vfs_backend_set_icon_name (backend, op_backend->icon_name);
++ if (op_backend->icon_name) {
++ GIcon *icon;
++
++ g_vfs_backend_set_icon_name (backend, op_backend->icon_name);
++ icon = g_themed_icon_new (op_backend->icon_name);
++ g_file_info_set_icon (info, icon);
++ g_object_unref (icon);
++ }
+ display = g_strdup_printf (_("%s on %s"), "/", op_backend->display_name);
+ g_file_info_set_display_name (info, display);
+ g_free (display);
diff --git a/gnome-base/gvfs/gvfs-1.0.3-r1.ebuild b/gnome-base/gvfs/gvfs-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..e7ddc30cc779
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.0.3-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3-r1.ebuild,v 1.1 2009/02/02 22:36:31 eva Exp $
+
+inherit autotools bash-completion gnome2 eutils
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="archive avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
+
+RDEPEND=">=dev-libs/glib-2.17.6
+ >=sys-apps/dbus-1.0
+ >=net-libs/libsoup-2.23.91
+ dev-libs/libxml2
+ net-misc/openssh
+ archive? ( app-arch/libarchive )
+ avahi? ( >=net-dns/avahi-0.6 )
+ cdda? (
+ >=sys-apps/hal-0.5.10
+ >=dev-libs/libcdio-0.78.2 )
+ fuse? ( sys-fs/fuse )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ hal? ( >=sys-apps/hal-0.5.10 )
+ bluetooth? (
+ dev-libs/dbus-glib
+ >=net-wireless/bluez-libs-3.12
+ dev-libs/expat )
+ gphoto2? ( >=media-libs/libgphoto2-2.4 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ samba? ( >=net-fs/samba-3 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/gtk-doc-am"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-http
+ --disable-bash-completion
+ $(use_enable archive)
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable hal)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)"
+
+ if use cdda && built_with_use dev-libs/libcdio minimal; then
+ ewarn
+ ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
+ ewarn "without the minimal USE flag."
+ die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix non posixy tests, bug #256305
+ epatch "${FILESDIR}/${P}-posixtest.patch"
+
+ # Fix themed icon for obexftp, bug #256890
+ epatch "${FILESDIR}/${P}-obexftp-icon.patch"
+
+ # Fix HTTP leaks, bug #256892
+ epatch "${FILESDIR}/${P}-http-leak.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ use bash-completion && \
+ dobashcompletion programs/gvfs-bash-completion.sh ${PN}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use bash-completion && bash-completion_pkg_postinst
+}
diff --git a/gnome-base/gvfs/gvfs-1.0.3-r11.ebuild b/gnome-base/gvfs/gvfs-1.0.3-r11.ebuild
new file mode 100644
index 000000000000..ff5c0a482ebc
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.0.3-r11.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3-r11.ebuild,v 1.1 2009/02/02 22:36:31 eva Exp $
+
+inherit autotools bash-completion gnome2 eutils
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="archive avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
+
+RDEPEND=">=dev-libs/glib-2.17.6
+ >=sys-apps/dbus-1.0
+ >=net-libs/libsoup-2.23.91
+ dev-libs/libxml2
+ net-misc/openssh
+ archive? ( app-arch/libarchive )
+ avahi? ( >=net-dns/avahi-0.6 )
+ cdda? (
+ >=sys-apps/hal-0.5.10
+ >=dev-libs/libcdio-0.78.2 )
+ fuse? ( sys-fs/fuse )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ hal? ( >=sys-apps/hal-0.5.10 )
+ bluetooth? (
+ dev-libs/dbus-glib
+ net-wireless/bluez
+ dev-libs/expat )
+ gphoto2? ( >=media-libs/libgphoto2-2.4 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ samba? ( >=net-fs/samba-3 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/gtk-doc-am"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-http
+ --disable-bash-completion
+ $(use_enable archive)
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable hal)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)"
+
+ if use cdda && built_with_use dev-libs/libcdio minimal; then
+ ewarn
+ ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
+ ewarn "without the minimal USE flag."
+ die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Add support for bluez 4, bug #250615
+ epatch "${FILESDIR}/${P}-bluez4.patch"
+
+ # Fix non posixy tests, bug #256305
+ epatch "${FILESDIR}/${P}-posixtest.patch"
+
+ # Fix themed icon for obexftp, bug #256890
+ epatch "${FILESDIR}/${P}-obexftp-icon.patch"
+
+ # Fix HTTP leaks, bug #256892
+ epatch "${FILESDIR}/${P}-http-leak.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ use bash-completion && \
+ dobashcompletion programs/gvfs-bash-completion.sh ${PN}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use bash-completion && bash-completion_pkg_postinst
+}