summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-13 18:19:02 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-13 18:19:02 +0000
commit2b171f9474e5b00a5b938d13687a54e99c60c4b4 (patch)
tree93e89510065ee13f89d799e5f5bd835e4a03b360 /gnome-base
parentenable font hinting, Apple have patent on this and as far I understand that i... (diff)
downloadgentoo-2-2b171f9474e5b00a5b938d13687a54e99c60c4b4.tar.gz
gentoo-2-2b171f9474e5b00a5b938d13687a54e99c60c4b4.tar.bz2
gentoo-2-2b171f9474e5b00a5b938d13687a54e99c60c4b4.zip
don't make gnome-support optional in libglade, causes problem for people trying to merge gnome without gnome in there USE
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libglade/files/digest-libglade-0.17-r31
-rw-r--r--gnome-base/libglade/libglade-0.17-r3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-base/libglade/files/digest-libglade-0.17-r3 b/gnome-base/libglade/files/digest-libglade-0.17-r3
new file mode 100644
index 000000000000..f5f91da05a20
--- /dev/null
+++ b/gnome-base/libglade/files/digest-libglade-0.17-r3
@@ -0,0 +1 @@
+MD5 38b2e2cfd813783fe157617813bfe3b3 libglade-0.17.tar.gz 425984
diff --git a/gnome-base/libglade/libglade-0.17-r3.ebuild b/gnome-base/libglade/libglade-0.17-r3.ebuild
new file mode 100644
index 000000000000..a865b99ba114
--- /dev/null
+++ b/gnome-base/libglade/libglade-0.17-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.17-r3.ebuild,v 1.1 2001/12/13 18:19:02 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libglade"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=dev-libs/libxml-1.8.15
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+# bonobo? ( >=gnome-base/bonobo-1.0.9-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myopts
+
+# Bonobo support creates a circular depend // Hallski
+# if [ "`use bonobo`" ]
+# then
+# myconf="--enable-bonobo --disable-bonobotest"
+# else
+# myconf="--disable-bonobo"
+# fi
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-gnomedb \
+ --disable-bonobo --disable-bonobotest \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc doc/*.txt
+}