summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-08 00:58:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-08 00:58:44 +0000
commit1c3514a94fd487b42ce768693d24cc95802b3997 (patch)
tree480a8fa9424c3717462a6d4ae938c0395e09adf7 /gnome-base
parentUpdate (diff)
downloadgentoo-2-1c3514a94fd487b42ce768693d24cc95802b3997.tar.gz
gentoo-2-1c3514a94fd487b42ce768693d24cc95802b3997.tar.bz2
gentoo-2-1c3514a94fd487b42ce768693d24cc95802b3997.zip
Update
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-core/files/digest-gnome-core-1.4.0.31
-rw-r--r--gnome-base/gnome-core/gnome-core-1.4.0.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/gnome-base/gnome-core/files/digest-gnome-core-1.4.0.3 b/gnome-base/gnome-core/files/digest-gnome-core-1.4.0.3
new file mode 100644
index 000000000000..8b95b617b16e
--- /dev/null
+++ b/gnome-base/gnome-core/files/digest-gnome-core-1.4.0.3
@@ -0,0 +1 @@
+MD5 0512beb2d3a70305f99107283d9c568f gnome-core-1.4.0.3.tar.gz
diff --git a/gnome-base/gnome-core/gnome-core-1.4.0.3.ebuild b/gnome-base/gnome-core/gnome-core-1.4.0.3.ebuild
new file mode 100644
index 000000000000..a7eee8cd3aa0
--- /dev/null
+++ b/gnome-base/gnome-core/gnome-core-1.4.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-core/gnome-core-1.4.0.3.ebuild,v 1.1 2001/05/08 00:58:44 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-core"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND="gtkhtml? ( >=gnome-base/gtkhtml-0.7 )
+ >=gnome-base/control-center-1.2.4
+ >=gnome-base/glibwww-0.2-r1
+ >=gnome-base/libghttp-1.0.9
+ >=gnome-base/libglade-0.16-r1
+ >=gnome-base/scrollkeeper-0.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/xml-i18n-tools-0.8
+ >=sys-devel/autoconf-2.13
+ >=sys-devel/automake-1.4"
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+# try NOCONFIGURE=yes srcdir=${S} bash macros/autogen.sh
+#}
+
+src_compile() {
+ local myconf
+ local myldflags
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ if [ "`use gtkhtml`" ]
+ then
+ myconf="${myconf} --enable-gtkhtml-help"
+ fi
+ if [ "`use kde`" ]
+ then
+ myconf="${myconf} --with-kde-datadir=/opt/kde2/share"
+ fi
+ try ./configure --host=${CHOST} --mandir=/opt/gnome/share/man \
+ --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome \
+ ${myconf}
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome mandir=${D}/opt/gnome/share/man install
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}
+
+
+
+
+
+
+
+