summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2004-08-21 14:56:09 +0000
committerMike Gardiner <obz@gentoo.org>2004-08-21 14:56:09 +0000
commitfd314703763796f2a775020e39246dff7b7f1c31 (patch)
treea54deb62e7e3fb197258398bbafd6c2b2a9fa73a /gnome-base/orbit
parentFirst version using the amalgamated orbit ebuild, combining ORBit and ORBit2 ... (diff)
downloadgentoo-2-fd314703763796f2a775020e39246dff7b7f1c31.tar.gz
gentoo-2-fd314703763796f2a775020e39246dff7b7f1c31.tar.bz2
gentoo-2-fd314703763796f2a775020e39246dff7b7f1c31.zip
Porting versions from ORBit2, pre-slot
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/Manifest7
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.10.01
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.10.21
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.10.31
-rw-r--r--gnome-base/orbit/orbit-2.10.0.ebuild34
-rw-r--r--gnome-base/orbit/orbit-2.10.2.ebuild46
-rw-r--r--gnome-base/orbit/orbit-2.10.3.ebuild36
7 files changed, 126 insertions, 0 deletions
diff --git a/gnome-base/orbit/Manifest b/gnome-base/orbit/Manifest
index bfcfdb814beb..4e9d26cc9d51 100644
--- a/gnome-base/orbit/Manifest
+++ b/gnome-base/orbit/Manifest
@@ -1,4 +1,11 @@
+MD5 3f67a9d02975bd10c939a43a05c6b85b orbit-2.10.3.ebuild 932
+MD5 c9b3f5dd89c4151382c337be34019efe .orbit-2.10.4.ebuild.swp 12288
+MD5 a54f93ba4f8fabc21dbaf4ee43a4d1d8 orbit-2.10.0.ebuild 890
+MD5 a422439ec1abb2c72c22100de0fd5803 orbit-2.10.2.ebuild 1298
MD5 e1a5cb8c2c0eabf2e0a4c03f3e0eb476 orbit-2.10.4.ebuild 1015
MD5 62fa66efe502e253f158b4c3358969f2 ChangeLog 412
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 b6e4b20cee3509d04f2651315328e1d5 files/digest-orbit-2.10.0 66
+MD5 8a5c202be9737ff8b7fce75d36f1c878 files/digest-orbit-2.10.2 66
+MD5 f951e87ddc66d6ef47ebd24cedbc8545 files/digest-orbit-2.10.3 66
MD5 763baa27841f44f10aa13a502816c867 files/digest-orbit-2.10.4 66
diff --git a/gnome-base/orbit/files/digest-orbit-2.10.0 b/gnome-base/orbit/files/digest-orbit-2.10.0
new file mode 100644
index 000000000000..95b8f3e8b444
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.10.0
@@ -0,0 +1 @@
+MD5 fe86ec038fc51ee0e90e84169a8dda6c ORBit2-2.10.0.tar.bz2 643687
diff --git a/gnome-base/orbit/files/digest-orbit-2.10.2 b/gnome-base/orbit/files/digest-orbit-2.10.2
new file mode 100644
index 000000000000..d1d2fc769497
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.10.2
@@ -0,0 +1 @@
+MD5 c862e3261b52a84321e89f57e5600da6 ORBit2-2.10.2.tar.bz2 649720
diff --git a/gnome-base/orbit/files/digest-orbit-2.10.3 b/gnome-base/orbit/files/digest-orbit-2.10.3
new file mode 100644
index 000000000000..4918a19c5f84
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.10.3
@@ -0,0 +1 @@
+MD5 17fee360a7d59271204b99d26899365f ORBit2-2.10.3.tar.bz2 649717
diff --git a/gnome-base/orbit/orbit-2.10.0.ebuild b/gnome-base/orbit/orbit-2.10.0.ebuild
new file mode 100644
index 000000000000..87322fe116ef
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.10.0.ebuild,v 1.1 2004/08/21 14:56:09 obz Exp $
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+IUSE="doc ssl"
+SLOT="2"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ppc alpha ~sparc hppa amd64 ~ia64 mips"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.7.4
+ dev-util/indent
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog COPYING* README* HACKING INSTALL NEWS TODO MAINTAINERS"
diff --git a/gnome-base/orbit/orbit-2.10.2.ebuild b/gnome-base/orbit/orbit-2.10.2.ebuild
new file mode 100644
index 000000000000..d42e03d9487b
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.10.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.10.2.ebuild,v 1.1 2004/08/21 14:56:09 obz Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+IUSE="doc ssl"
+SLOT="2"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ~ppc ~alpha ~sparc ~hppa amd64 ~ia64 ~mips ppc64"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.7.4
+ dev-util/indent
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog COPYING* README* HACKING INSTALL NEWS TODO MAINTAINERS"
+
+src_unpack() {
+ unpack ${A}
+
+ # this patch fixes a bug in CORBA_free() where it doesnt take proper
+ # structure alignment into account. the nautilus bug on amd64, alpha, and
+ # various other non-x86 archs that caused it to segfault with more than
+ # two fstab entries with the user option is now fixed.
+ cd ${S} ; epatch ${FILESDIR}/orbit2-alignment-fix.patch
+}
diff --git a/gnome-base/orbit/orbit-2.10.3.ebuild b/gnome-base/orbit/orbit-2.10.3.ebuild
new file mode 100644
index 000000000000..4844d922163f
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.10.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.10.3.ebuild,v 1.1 2004/08/21 14:56:09 obz Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+IUSE="doc ssl"
+SLOT="2"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ~ppc alpha sparc hppa amd64 ia64 ~mips ~ppc64"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.7.4
+ dev-util/indent
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog COPYING* README* HACKING INSTALL NEWS TODO MAINTAINERS"