summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-10 09:44:17 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-10 09:44:17 +0000
commite2607ee84d1979e7dd9b1b685dc6e31784059a88 (patch)
treeb0403eb4d446ca50c48d522c3474e1263fc68bc7 /gnome-base/nautilus
parentNLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) and gpm depen... (diff)
downloadgentoo-2-e2607ee84d1979e7dd9b1b685dc6e31784059a88.tar.gz
gentoo-2-e2607ee84d1979e7dd9b1b685dc6e31784059a88.tar.bz2
gentoo-2-e2607ee84d1979e7dd9b1b685dc6e31784059a88.zip
NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/ChangeLog11
-rw-r--r--gnome-base/nautilus/files/digest-nautilus-1.0.6-r41
-rw-r--r--gnome-base/nautilus/nautilus-1.0.6-r4.ebuild91
3 files changed, 101 insertions, 2 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index 601d58bf4f08..9b5af266ad00 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for gnome-base/nautilus
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.2 2002/03/07 06:27:56 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.3 2002/03/10 09:44:17 blocke Exp $
+*nautilus-1.0.6-r4 (10 Mar 2002)
+
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> nautilus-1.0.6-r4.ebuild :
+
+ NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
+
+
*nautilus-1.0.6-r3 (7 Mar 2002)
- 7 Mar 2002; Bruce A. Locke <blocke@gentoo.org> nautilus-1.0.6-r3.ebuild :
+ 7 Mar 2002; Bruce A. Locke <blocke@shivan.org> nautilus-1.0.6-r3.ebuild :
Applied a patch from Mandrake brought to our attention by Naresh Donti
(ndonti@ndonti.dynodns.net). A temporary patch to hyperbola to prevent
diff --git a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r4 b/gnome-base/nautilus/files/digest-nautilus-1.0.6-r4
new file mode 100644
index 000000000000..618f369df464
--- /dev/null
+++ b/gnome-base/nautilus/files/digest-nautilus-1.0.6-r4
@@ -0,0 +1 @@
+MD5 436283056c100bcbd14098a5342e2868 nautilus-1.0.6.tar.gz 11481232
diff --git a/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild b/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild
new file mode 100644
index 000000000000..ff485bd2f8d4
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# Updated by Sebastian Werner <sebastian@werner-productions.de>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild,v 1.1 2002/03/10 09:44:17 blocke Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="nautilus"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND="mozilla? ( >=net-www/mozilla-0.9.5 )
+ >=app-admin/fam-oss-2.6.4
+ >=media-sound/cdparanoia-3.9.8
+ >=gnome-base/bonobo-1.0.9-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1
+ >=gnome-base/libghttp-1.0.9-r1
+ >=gnome-base/gnome-vfs-1.0.3
+ >=gnome-base/librsvg-1.0.1
+ >=gnome-base/eel-1.0.2
+ >=gnome-extra/medusa-0.5.1-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=app-text/scrollkeeper-0.2
+ >=dev-util/intltool-0.11"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ # The following is a temporary patch contributed by Naresh Donti
+ # to fix the 50 defunct copies of sh caused by hyperbola. This patch
+ # will no longer be needed with a future version of scrollkeeper.
+ # see bug #566 for more information
+
+ patch -p0 < ${FILESDIR}/nautilus-1.0.6-hyperbola.diff
+
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ if [ "`use mozilla`" ]
+ then
+ MOZILLA=${MOZILLA_FIVE_HOME}
+ myconf="${myconf} --with-mozilla-lib-place=$MOZILLA \
+ --with-mozilla-include-place=$MOZILLA/include"
+
+ export MOZILLA_FIVE_HOME=$MOZILLA
+ export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME
+ else
+ myconf="${myconf} --disable-mozilla-component"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-eazel-services=0 \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ # Fix missing icon in Gnome Spash
+ insinto /usr/share/pixmaps
+ newins nautilus-launch-icon.png gnome-launch-icon.png
+
+ dodoc AUTHORS COPYING* ChangeLog* NEWS TODO
+
+ # Fix permissions in order to resolve the mozilla-view issue
+ chmod -R g+r,o+r ${D}/*
+}