summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-11-01 06:32:20 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-11-01 06:32:20 +0000
commit847f043b3adcdf38c0d5d7ff445ffb4e2c900c47 (patch)
tree48631f3a9884b925838e2c92ff087e165f0a24e2 /gnome-base/libgnome
parentDont bother creating a /dev/fuse device node #152032 by Mike Kelly. (diff)
downloadgentoo-2-847f043b3adcdf38c0d5d7ff445ffb4e2c900c47.tar.gz
gentoo-2-847f043b3adcdf38c0d5d7ff445ffb4e2c900c47.tar.bz2
gentoo-2-847f043b3adcdf38c0d5d7ff445ffb4e2c900c47.zip
Fixed autotools dependencies (bug #151530). Pruning old ebuilds/patches.
(Portage version: 2.1.2_rc1)
Diffstat (limited to 'gnome-base/libgnome')
-rw-r--r--gnome-base/libgnome/ChangeLog6
-rw-r--r--gnome-base/libgnome/libgnome-2.14.1.ebuild22
-rw-r--r--gnome-base/libgnome/libgnome-2.16.0.ebuild24
3 files changed, 31 insertions, 21 deletions
diff --git a/gnome-base/libgnome/ChangeLog b/gnome-base/libgnome/ChangeLog
index 5f8c0e9acea3..78c7106cdc62 100644
--- a/gnome-base/libgnome/ChangeLog
+++ b/gnome-base/libgnome/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/libgnome
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/ChangeLog,v 1.124 2006/10/19 15:31:12 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/ChangeLog,v 1.125 2006/11/01 06:32:20 leonardop Exp $
+
+ 01 Nov 2006; Leonardo Boshell <leonardop@gentoo.org>
+ libgnome-2.14.1.ebuild, libgnome-2.16.0.ebuild:
+ Inherit from autotools in order to fix dependency problems (bug #151530).
19 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> libgnome-2.14.1.ebuild:
Stable on Alpha.
diff --git a/gnome-base/libgnome/libgnome-2.14.1.ebuild b/gnome-base/libgnome/libgnome-2.14.1.ebuild
index fc514d9ef460..60c58145be0e 100644
--- a/gnome-base/libgnome/libgnome-2.14.1.ebuild
+++ b/gnome-base/libgnome/libgnome-2.14.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.14.1.ebuild,v 1.12 2006/10/19 15:31:12 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.14.1.ebuild,v 1.13 2006/11/01 06:32:20 leonardop Exp $
-inherit eutils gnome2
+WANT_AUTOMAKE=1.7
+
+inherit autotools gnome2
DESCRIPTION="Essential Gnome Libraries"
HOMEPAGE="http://www.gnome.org/"
@@ -17,7 +19,8 @@ RDEPEND=">=dev-libs/glib-2.8
>=gnome-base/libbonobo-2.13
>=gnome-base/gnome-vfs-2.5.3
>=dev-libs/popt-1.5
- esd? ( >=media-sound/esound-0.2.26
+ esd? (
+ >=media-sound/esound-0.2.26
>=media-libs/audiofile-0.2.3 )"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.28
@@ -26,15 +29,16 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
+
pkg_setup() {
- G2CONF="${G2CONF} --disable-schemas-install $(use_enable static) $(use_enable esd)"
+ G2CONF="${G2CONF} --disable-schemas-install \
+ $(use_enable static) \
+ $(use_enable esd)"
}
src_unpack() {
- unpack ${A}
- cd "${S}"
- export WANT_AUTOMAKE=1.7
+ gnome2_src_unpack
+
cp aclocal.m4 old_macros.m4
- aclocal -I . || die "aclocal failed"
- autoconf || die "autoconf failed"
+ AT_M4DIR="." eautoreconf
}
diff --git a/gnome-base/libgnome/libgnome-2.16.0.ebuild b/gnome-base/libgnome/libgnome-2.16.0.ebuild
index de7244ed2801..35f1804d4fd4 100644
--- a/gnome-base/libgnome/libgnome-2.16.0.ebuild
+++ b/gnome-base/libgnome/libgnome-2.16.0.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.16.0.ebuild,v 1.2 2006/09/12 14:29:47 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.16.0.ebuild,v 1.3 2006/11/01 06:32:20 leonardop Exp $
-inherit eutils gnome2
+WANT_AUTOMAKE=1.7
+
+inherit autotools gnome2
DESCRIPTION="Essential Gnome Libraries"
HOMEPAGE="http://www.gnome.org/"
@@ -17,10 +19,10 @@ RDEPEND=">=dev-libs/glib-2.8
>=gnome-base/libbonobo-2.13
>=gnome-base/gnome-vfs-2.5.3
>=dev-libs/popt-1.7
- esd? (
- >=media-sound/esound-0.2.26
- >=media-libs/audiofile-0.2.3
- )"
+ esd? (
+ >=media-sound/esound-0.2.26
+ >=media-libs/audiofile-0.2.3 )"
+
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
>=dev-util/pkgconfig-0.17
@@ -28,16 +30,16 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
+
pkg_setup() {
- G2CONF="${G2CONF} --disable-schemas-install $(use_enable static) $(use_enable esd)"
+ G2CONF="${G2CONF} --disable-schemas-install \
+ $(use_enable static) \
+ $(use_enable esd)"
}
src_unpack() {
gnome2_src_unpack
- export WANT_AUTOMAKE=1.7
-
cp aclocal.m4 old_macros.m4
- aclocal -I . || die "aclocal failed"
- autoconf || die "autoconf failed"
+ AT_M4DIR="." eautoreconf
}