summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-07 03:41:55 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-07 03:41:55 +0000
commit1876f546f32942b264aae974f92c4a873b9f0f80 (patch)
tree60cd77835a0c2541eadf13aba710f2bcf76baba3 /gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild
parentgnome 2.16 (diff)
downloadgentoo-2-1876f546f32942b264aae974f92c4a873b9f0f80.tar.gz
gentoo-2-1876f546f32942b264aae974f92c4a873b9f0f80.tar.bz2
gentoo-2-1876f546f32942b264aae974f92c4a873b9f0f80.zip
gnome 2.16
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild')
-rw-r--r--gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild b/gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild
new file mode 100644
index 000000000000..afc62fb39ef1
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/libbonoboui-2.16.0.ebuild,v 1.1 2006/09/07 03:41:55 dang Exp $
+
+inherit eutils virtualx gnome2
+
+DESCRIPTION="User Interface part of libbonobo"
+HOMEPAGE="http://developer.gnome.org/arch/gnome/componentmodel/bonobo.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc"
+
+# GTK+ dep due to bug #126565
+RDEPEND=">=gnome-base/libgnomecanvas-1.116
+ >=gnome-base/libbonobo-2.13
+ >=gnome-base/libgnome-2.13.7
+ >=dev-libs/libxml2-2.4.20
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.8.12
+ >=gnome-base/libglade-1.99.11"
+
+DEPEND="${RDEPEND}
+ x11-apps/xrdb
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_test() {
+ Xmake check || die
+}