summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-30 00:59:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-30 00:59:34 +0000
commitf8523b69565d9651caf7faaccc4c78bb0b2dbf58 (patch)
tree492ef10db3b9c4fb1932d3d399cd1ed4cc8afce9 /gnome-base/gnome-print
parentSRC_URI fix (diff)
downloadgentoo-2-f8523b69565d9651caf7faaccc4c78bb0b2dbf58.tar.gz
gentoo-2-f8523b69565d9651caf7faaccc4c78bb0b2dbf58.tar.bz2
gentoo-2-f8523b69565d9651caf7faaccc4c78bb0b2dbf58.zip
Removed libglade from the dependency list, as it is not required. This sorts out circular dependency issues.
Diffstat (limited to 'gnome-base/gnome-print')
-rw-r--r--gnome-base/gnome-print/ChangeLog10
-rw-r--r--gnome-base/gnome-print/files/digest-gnome-print-0.35-r31
-rw-r--r--gnome-base/gnome-print/gnome-print-0.35-r3.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/gnome-base/gnome-print/ChangeLog b/gnome-base/gnome-print/ChangeLog
index ca216e0437c9..fbf206f6c70b 100644
--- a/gnome-base/gnome-print/ChangeLog
+++ b/gnome-base/gnome-print/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-print
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/ChangeLog,v 1.3 2002/03/18 12:22:55 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/ChangeLog,v 1.4 2002/03/30 00:59:34 seemant Exp $
+
+*gnome-print-0.35-r3 (29 Mar 2002)
+
+ 29 Mar 2002; Seemant Kulleen <seemant@gentoo.org> gnome-print-0.35-r3.ebuild :
+
+ libglade is not a necessary compile-time or run-time dependency. As such,
+ this finally sorts out the libglade/bonobo/gnome-print circular dependency
+ issue, and libglade can now be compiled with bonobo support.
*gnome-print-0.35-r2 (18 Mar 2002)
diff --git a/gnome-base/gnome-print/files/digest-gnome-print-0.35-r3 b/gnome-base/gnome-print/files/digest-gnome-print-0.35-r3
new file mode 100644
index 000000000000..86024ae64c0d
--- /dev/null
+++ b/gnome-base/gnome-print/files/digest-gnome-print-0.35-r3
@@ -0,0 +1 @@
+MD5 65e0e91bfa43f01debfa12d25c5dc70b gnome-print-0.35.tar.gz 991657
diff --git a/gnome-base/gnome-print/gnome-print-0.35-r3.ebuild b/gnome-base/gnome-print/gnome-print-0.35-r3.ebuild
new file mode 100644
index 000000000000..1df0b9228ea7
--- /dev/null
+++ b/gnome-base/gnome-print/gnome-print-0.35-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.35-r3.ebuild,v 1.1 2002/03/30 00:59:34 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME printing library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=media-libs/gdk-pixbuf-0.11.0-r1
+ >=gnome-base/gnome-libs-1.4.1.4
+ >=media-libs/freetype-2.0.1"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ tex? ( app-text/tetex )
+ >=app-text/ghostscript-6.50-r2
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ #fix Makefile not to run gnome-font-install
+ cp ${S}/installer/Makefile.in ${S}/installer/Makefile.in.orig
+ sed -e 's:$(PERL) \($(top_srcdir)/run-gnome-font-install\):echo \1:' \
+ ${S}/installer/Makefile.in.orig > ${S}/installer/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ gnulocaledir=${D}/usr/share/locale \
+ sysconfdir=${D}/etc \
+ install || die
+
+ insinto /usr/share/fonts
+ doins ${S}/run-gnome-font-install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ldconfig >/dev/null 2>/dev/null
+ echo ">>> Installing fonts..."
+ perl /usr/share/fonts/run-gnome-font-install \
+ /usr/bin/gnome-font-install \
+ /usr/share/fonts /usr/share/fonts /etc >/dev/null 2>/dev/null
+}
+