summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-04-19 07:26:06 +0000
committerMart Raudsepp <leio@gentoo.org>2009-04-19 07:26:06 +0000
commitbdfed329b2f99b4bfba42c77a22aabc226c72753 (patch)
tree19a90e1cf15577ddc0b44342d437d2877dc3ba88 /gnome-base/gconf
parentAdded stable version (required by libnc-dap) and removed die from test. (diff)
downloadgentoo-2-bdfed329b2f99b4bfba42c77a22aabc226c72753.tar.gz
gentoo-2-bdfed329b2f99b4bfba42c77a22aabc226c72753.tar.bz2
gentoo-2-bdfed329b2f99b4bfba42c77a22aabc226c72753.zip
New version: --toggle and --search-key-regexp support in gconftool-2; size and parsing speed improvements in saved gconf setting trees; bug fixes
(Portage version: 2.2_rc22/cvs/Linux 2.6.29-gentoo-r1 x86_64)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog8
-rw-r--r--gnome-base/gconf/gconf-2.26.0.ebuild101
2 files changed, 108 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 02e23cf21d76..dd70dcbcf5a6 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.204 2009/04/12 20:41:22 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.205 2009/04/19 07:26:06 leio Exp $
+
+*gconf-2.26.0 (19 Apr 2009)
+
+ 19 Apr 2009; Mart Raudsepp <leio@gentoo.org> +gconf-2.26.0.ebuild:
+ New version: --toggle and --search-key-regexp support in gconftool-2; size
+ and parsing speed improvements in saved gconf setting trees; bug fixes
12 Apr 2009; Friedrich Oslage <bluebird@gentoo.org> gconf-2.24.0.ebuild:
Stable on sparc, bug #260063
diff --git a/gnome-base/gconf/gconf-2.26.0.ebuild b/gnome-base/gconf/gconf-2.26.0.ebuild
new file mode 100644
index 000000000000..06c9c4167211
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.26.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.26.0.ebuild,v 1.1 2009/04/19 07:26:06 leio Exp $
+
+inherit autotools eutils gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug doc ldap policykit"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.8.16
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ ldap? ( net-nds/openldap )
+ policykit? ( >=sys-auth/policykit-0.7 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gtk
+ --disable-defaults-service
+ --disable-static
+ $(use_enable debug)
+ $(use_with ldap openldap)
+ $(use_enable policykit defaults-service)"
+ kill_gconf
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #193442, GNOME bug #498934
+ epatch "${FILESDIR}/${PN}-2.24.0-automagic-ldap.patch"
+
+ # fix bug #238276
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ eautoreconf
+}
+
+# Can't run tests, missing script.
+#src_test() {
+# emake -C tests || die "make tests failed"
+# sh "${S}"/tests/runtests.sh || die "running tests failed"
+#}
+
+src_install() {
+ gnome2_src_install
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die "doenv failed"
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}