summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-13 15:41:46 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-13 15:41:46 +0000
commiteb99c3e60b62ff194b4fbc30e4faa300a5583c26 (patch)
tree504645879846a4fcf3ae777bbae611f1e30d9ce7 /games-util
parentDrop old (diff)
downloadgentoo-2-eb99c3e60b62ff194b4fbc30e4faa300a5583c26.tar.gz
gentoo-2-eb99c3e60b62ff194b4fbc30e4faa300a5583c26.tar.bz2
gentoo-2-eb99c3e60b62ff194b4fbc30e4faa300a5583c26.zip
add gcc-4.7 version check wrt #480874
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/higan-purify/ChangeLog5
-rw-r--r--games-util/higan-purify/higan-purify-03.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/games-util/higan-purify/ChangeLog b/games-util/higan-purify/ChangeLog
index d88f10280281..5099fe43c3d1 100644
--- a/games-util/higan-purify/ChangeLog
+++ b/games-util/higan-purify/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-util/higan-purify
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/higan-purify/ChangeLog,v 1.1 2013/06/09 19:18:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/higan-purify/ChangeLog,v 1.2 2013/08/13 15:41:46 hasufell Exp $
+
+ 13 Aug 2013; Julian Ospald <hasufell@gentoo.org> higan-purify-03.ebuild:
+ add gcc-4.7 version check wrt #480874
*higan-purify-03 (09 Jun 2013)
diff --git a/games-util/higan-purify/higan-purify-03.ebuild b/games-util/higan-purify/higan-purify-03.ebuild
index a6ace92a490c..a8b8578ba49a 100644
--- a/games-util/higan-purify/higan-purify-03.ebuild
+++ b/games-util/higan-purify/higan-purify-03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/higan-purify/higan-purify-03.ebuild,v 1.1 2013/06/09 19:18:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/higan-purify/higan-purify-03.ebuild,v 1.2 2013/08/13 15:41:46 hasufell Exp $
EAPI=5
@@ -26,6 +26,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}/purify
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 7 || $(gcc-major-version) -lt 4 ]] ; then
+ eerror "You need at least sys-devel/gcc-4.7.0"
+ die "You need at least sys-devel/gcc-4.7.0"
+ fi
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-QA.patch
sed -i \