summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-07-22 19:03:35 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-07-22 19:03:35 +0000
commit9e3f8adee67f9559d9a1653d1a0b817dc9478a3a (patch)
treed0a956d86c00f3fd7f4aebb1b8d59679e361d269 /games-util
parentDropped amd64 keyword because of bug #162048. (diff)
downloadgentoo-2-9e3f8adee67f9559d9a1653d1a0b817dc9478a3a.tar.gz
gentoo-2-9e3f8adee67f9559d9a1653d1a0b817dc9478a3a.tar.bz2
gentoo-2-9e3f8adee67f9559d9a1653d1a0b817dc9478a3a.zip
Fix building with gcc-4.3 Bug #232445
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog8
-rw-r--r--games-util/atlas/atlas-0.3.1.ebuild7
-rw-r--r--games-util/atlas/files/atlas-0.3.1-gcc-4.3.patch10
3 files changed, 20 insertions, 5 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index 48fc8f232ca5..afcf0a16bc50 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/atlas
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.14 2007/12/26 00:12:19 tupone Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.15 2008/07/22 19:03:34 tupone Exp $
+
+ 22 Jul 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/atlas-0.3.1-gcc-4.3.patch, atlas-0.3.1.ebuild:
+ Fix building with gcc-4.3 Bug #232445 by <bugs@dev.gentooexperimental.org>
26 Dec 2007; Tupone Alfredo <tupone@gentoo.org>
+files/atlas-0.3.1-simgearNew.patch, atlas-0.3.1.ebuild:
diff --git a/games-util/atlas/atlas-0.3.1.ebuild b/games-util/atlas/atlas-0.3.1.ebuild
index 7f624fd9393c..190368692f16 100644
--- a/games-util/atlas/atlas-0.3.1.ebuild
+++ b/games-util/atlas/atlas-0.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1.ebuild,v 1.4 2007/12/26 00:12:19 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1.ebuild,v 1.5 2008/07/22 19:03:34 tupone Exp $
inherit eutils autotools games
@@ -25,7 +25,8 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-simgearNew.patch
+ epatch "${FILESDIR}"/${P}-simgearNew.patch \
+ "${FILESDIR}"/${P}-gcc-4.3.patch
eautoreconf
}
diff --git a/games-util/atlas/files/atlas-0.3.1-gcc-4.3.patch b/games-util/atlas/files/atlas-0.3.1-gcc-4.3.patch
new file mode 100644
index 000000000000..044c6f1b862f
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.3.1-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- src/fg_mkdir.cxx.old 2008-07-22 20:51:25.000000000 +0200
++++ src/fg_mkdir.cxx 2008-07-22 20:52:30.000000000 +0200
+@@ -34,6 +34,7 @@
+ #endif
+ #include <string.h>
+ #include <string>
++#include <stdlib.h>
+
+ using namespace std;
+