summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-01 18:26:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-01 18:26:38 +0000
commit53ece2a37f2fc76e435b856f46fb02ae399ed9ad (patch)
tree156984c6598a45d9e8f9791c50374841e0b039fd /games-util
parentfix typo causing skip of eselect (bug #343723) (diff)
downloadgentoo-2-53ece2a37f2fc76e435b856f46fb02ae399ed9ad.tar.gz
gentoo-2-53ece2a37f2fc76e435b856f46fb02ae399ed9ad.tar.bz2
gentoo-2-53ece2a37f2fc76e435b856f46fb02ae399ed9ad.zip
New snapshot wrt #315409.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog8
-rw-r--r--games-util/atlas/atlas-0.3.1_p20101101.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index e74950438850..e8b16b8d5658 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/atlas
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.22 2010/10/14 20:26:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.23 2010/11/01 18:26:38 ssuominen Exp $
+
+*atlas-0.3.1_p20101101 (01 Nov 2010)
+
+ 01 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +atlas-0.3.1_p20101101.ebuild:
+ New snapshot wrt #315409.
14 Oct 2010; Brent Baude <ranger@gentoo.org> atlas-0.3.1_p20100302.ebuild:
Marking atlas-0.3.1_p20100302 ppc for bug 313613
diff --git a/games-util/atlas/atlas-0.3.1_p20101101.ebuild b/games-util/atlas/atlas-0.3.1_p20101101.ebuild
new file mode 100644
index 000000000000..e56ef4e761b9
--- /dev/null
+++ b/games-util/atlas/atlas-0.3.1_p20101101.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1_p20101101.ebuild,v 1.1 2010/11/01 18:26:38 ssuominen Exp $
+
+EAPI=2
+inherit autotools games
+
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=games-simulation/flightgear-2
+ media-libs/freeglut
+ >=media-libs/libpng-1.4
+ media-libs/plib
+ net-misc/curl
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXmu"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-fgbase="${GAMES_DATADIR}"/FlightGear
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas
+ doins src/data/*.{jpg,png} || die
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas/Palettes
+ doins src/data/Palettes/*.ap || die
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas/Fonts
+ doins src/data/Fonts/*.txf || die
+ dodoc AUTHORS NEWS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You now can make the maps with the following commands:"
+ elog "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/FlightGear/Atlas"
+ elog
+ elog "To run Atlas concurrently with FlightGear use the following:"
+ elog "Atlas --path=[path of map images] --udp=[port number]"
+ elog "and start fgfs with the following switch (or in .fgfsrc):"
+ elog "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ elog "You must manually remove the maps if you don't want them around."
+ elog "They are found in the following directory:"
+ echo
+ elog "${GAMES_DATADIR}/FlightGear/Atlas"
+ echo
+}