summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-29 21:05:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-29 21:05:12 +0000
commit1ae0dd34b897779cf1c565ecaf3ebfc78cbe3e08 (patch)
tree4962b014acaf4f0d6ae3d646dba232f6ac88ccc4 /games-util
parentpkgmove freefont-ttf to freefont (diff)
downloadgentoo-2-1ae0dd34b897779cf1c565ecaf3ebfc78cbe3e08.tar.gz
gentoo-2-1ae0dd34b897779cf1c565ecaf3ebfc78cbe3e08.tar.bz2
gentoo-2-1ae0dd34b897779cf1c565ecaf3ebfc78cbe3e08.zip
version bump (bug #454126)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/grfcodec/ChangeLog10
-rw-r--r--games-util/grfcodec/grfcodec-6.0.2.ebuild47
2 files changed, 54 insertions, 3 deletions
diff --git a/games-util/grfcodec/ChangeLog b/games-util/grfcodec/ChangeLog
index c4b65aad9961..7d3bdfd5ca23 100644
--- a/games-util/grfcodec/ChangeLog
+++ b/games-util/grfcodec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/grfcodec
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.16 2012/10/31 13:41:33 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.17 2013/01/29 21:05:12 mr_bones_ Exp $
+
+*grfcodec-6.0.2 (29 Jan 2013)
+
+ 29 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> +grfcodec-6.0.2.ebuild:
+ version bump (bug #454126)
31 Oct 2012; Tupone Alfredo <tupone@gentoo.org> -grfcodec-5.1.1.ebuild:
Removed old version affected by Bug #320797 from Diego
@@ -64,4 +69,3 @@
+metadata.xml:
initial commit - ebuild and patch submitted by Locke 'Wizzleby' Shinseiko
via bug #300328
-
diff --git a/games-util/grfcodec/grfcodec-6.0.2.ebuild b/games-util/grfcodec/grfcodec-6.0.2.ebuild
new file mode 100644
index 000000000000..bee0d225be5c
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-6.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-6.0.2.ebuild,v 1.1 2013/01/29 21:05:12 mr_bones_ Exp $
+
+EAPI=5
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
+[[ -z ${SCM} ]] && SRC_URI="http://binaries.openttd.org/extra/${PN}/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+[[ -n ${SCM} ]] && S=${WORKDIR}/${PN}
+
+DEPEND="!games-util/nforenum
+ dev-lang/perl
+ dev-libs/boost
+ media-libs/libpng:0"
+RDEPEND=""
+
+src_prepare() {
+# Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
+cat > Makefile.local <<-__EOF__
+ CXX = $(tc-getCXX)
+ CXXFLAGS = ${CXXFLAGS}
+ LDOPT = ${LDFLAGS}
+ UPX =
+ V = 1
+ FLAGS=
+ __EOF__
+}
+
+src_install() {
+ dobin ${PN} grf{diff,id,merge} nforenum
+ doman docs/*.1
+ dodoc changelog.txt docs/*.txt
+}