summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-13 00:10:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-13 00:10:57 +0000
commitec24f5335a5ce74733dbc5a3de69c2aef70f5780 (patch)
treeb4fc671de9207feb1b3e4328bee93a4609355fdc /games-strategy
parentAdd ~alpha keyword. (diff)
downloadgentoo-2-ec24f5335a5ce74733dbc5a3de69c2aef70f5780.tar.gz
gentoo-2-ec24f5335a5ce74733dbc5a3de69c2aef70f5780.tar.bz2
gentoo-2-ec24f5335a5ce74733dbc5a3de69c2aef70f5780.zip
Add a hack workaround since function seems to be rewritten in upstream CVS and it currently doesnt parse NVIDIA version properly #95696.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glest/ChangeLog7
-rw-r--r--games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch8
-rw-r--r--games-strategy/glest/glest-1.0.10_p7.ebuild5
3 files changed, 17 insertions, 3 deletions
diff --git a/games-strategy/glest/ChangeLog b/games-strategy/glest/ChangeLog
index 5f6a538ad1ae..7e860d14f84d 100644
--- a/games-strategy/glest/ChangeLog
+++ b/games-strategy/glest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glest
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.2 2005/04/12 09:39:13 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.3 2005/06/13 00:10:56 vapier Exp $
+
+ 13 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/glest-1.0.10_p7-fake-checkGlCaps.patch, glest-1.0.10_p7.ebuild:
+ Add a hack workaround since function seems to be rewritten in upstream CVS
+ and it currently doesnt parse NVIDIA version properly #95696.
12 Apr 2005; David Holm <dholm@gentoo.org> glest-1.0.10_p7.ebuild:
Added to ~ppc.
diff --git a/games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch b/games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch
new file mode 100644
index 000000000000..9efe40afeaf1
--- /dev/null
+++ b/games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch
@@ -0,0 +1,8 @@
+--- sources/renderer.cpp.orig 2005-06-12 20:06:38.000000000 -0400
++++ sources/renderer.cpp 2005-06-12 20:06:53.000000000 -0400
+@@ -2243,4 +2243,5 @@
+
+ void Renderer::checkGlCaps() {
++return;
+ //opengl 1.3
+ if(!isGlVersionSupported(1, 3, 0)) {
diff --git a/games-strategy/glest/glest-1.0.10_p7.ebuild b/games-strategy/glest/glest-1.0.10_p7.ebuild
index 15553a7db333..601008188df5 100644
--- a/games-strategy/glest/glest-1.0.10_p7.ebuild
+++ b/games-strategy/glest/glest-1.0.10_p7.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-1.0.10_p7.ebuild,v 1.3 2005/04/20 02:48:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-1.0.10_p7.ebuild,v 1.4 2005/06/13 00:10:56 vapier Exp $
inherit eutils games
DATAVERSION="${PV/_p?/}"
SOURCEVERSION="${PV/_p/-r}"
DESCRIPTION="Cross-platform 3D realtime strategy game"
-HOMEPAGE="http://www.stud.uni-karlsruhe.de/~uxsm/glest/"
+HOMEPAGE="http://www.glest.org/"
SRC_URI="http://www.stud.uni-karlsruhe.de/~uxsm/glest-${SOURCEVERSION}-source.tar.bz2
http://www.stud.uni-karlsruhe.de/~unatc/glest/glest-${DATAVERSION}-data.tar.bz2
linguas_de? ( http://www.stud.uni-karlsruhe.de/~uxsm/german.lng )
@@ -35,6 +35,7 @@ S=${WORKDIR}/${PN}-${DATAVERSION}
src_unpack() {
unpack glest-${SOURCEVERSION}-source.tar.bz2 glest-${DATAVERSION}-data.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/${P}-fake-checkGlCaps.patch
# sometimes they package configure, sometimes they dont
if [[ ! -e configure ]] ; then
./autogen.sh || die "autogen failed"