summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-04 21:15:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-04 21:15:32 +0000
commit7a6b90b0b4cdcf3857d769f9b11dcaea6a889f12 (patch)
treebc8c378ead353f8f74ce068d1afff3a5ef74094b /games-strategy
parentMark arm/ppc/sparc stable #508570 by Tim Harder. (diff)
downloadgentoo-2-7a6b90b0b4cdcf3857d769f9b11dcaea6a889f12.tar.gz
gentoo-2-7a6b90b0b4cdcf3857d769f9b11dcaea6a889f12.tar.bz2
gentoo-2-7a6b90b0b4cdcf3857d769f9b11dcaea6a889f12.zip
version bump (bug #512344)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/asc/ChangeLog10
-rw-r--r--games-strategy/asc/asc-2.6.0.0.ebuild72
2 files changed, 79 insertions, 3 deletions
diff --git a/games-strategy/asc/ChangeLog b/games-strategy/asc/ChangeLog
index ac80e87d9566..bd1a53571ddc 100644
--- a/games-strategy/asc/ChangeLog
+++ b/games-strategy/asc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/asc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.43 2012/10/30 15:07:24 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.44 2014/06/04 21:15:32 mr_bones_ Exp $
+
+*asc-2.6.0.0 (04 Jun 2014)
+
+ 04 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> +asc-2.6.0.0.ebuild:
+ version bump (bug #512344)
30 Oct 2012; Tupone Alfredo <tupone@gentoo.org> asc-2.5.0.0.ebuild,
+files/asc-2.5.0.0-gcc47.patch:
@@ -203,4 +208,3 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
-
diff --git a/games-strategy/asc/asc-2.6.0.0.ebuild b/games-strategy/asc/asc-2.6.0.0.ebuild
new file mode 100644
index 000000000000..849842fbb901
--- /dev/null
+++ b/games-strategy/asc/asc-2.6.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.6.0.0.ebuild,v 1.1 2014/06/04 21:15:32 mr_bones_ Exp $
+
+EAPI=5
+WX_GTK_VER=2.8
+inherit eutils toolchain-funcs flag-o-matic wxwidgets games
+
+DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
+HOMEPAGE="http://www.asc-hq.org/"
+SRC_URI="mirror://sourceforge/asc-hq/${P}.tar.bz2
+ http://www.asc-hq.org/music/frontiers.ogg
+ http://www.asc-hq.org/music/time_to_strike.ogg
+ http://www.asc-hq.org/music/machine_wars.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ media-libs/libsdl[video]
+ media-libs/libpng
+ media-libs/sdl-image[gif,jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-sound
+ dev-libs/boost
+ dev-games/physfs
+ media-libs/xvid
+ dev-libs/expat
+ media-libs/freetype
+ dev-lang/lua
+ x11-libs/wxGTK:2.8[X]
+ dev-libs/libsigc++:1.2"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ app-arch/zip"
+
+src_unpack() {
+ local f
+
+ unpack ${P}.tar.bz2
+ for f in ${A}
+ do
+ case ${f} in
+ *ogg)
+ cp "${DISTDIR}/${f}" "${S}/data/music" || die
+ ;;
+ esac
+ done
+}
+
+src_configure() {
+ # Added --disable-paraguitest for bugs 26402 and 4488
+ # Added --disable-paragui for bug 61154 since it's not really used much
+ # and the case is well documented at http://www.asc-hq.org/
+ if [[ $(gcc-major-version) -eq 4 ]] ; then
+ replace-flags -O3 -O2
+ fi
+ egamesconf \
+ --disable-paraguitest \
+ --disable-paragui \
+ --datadir="${GAMES_DATADIR_BASE}"
+}
+
+src_install() {
+ default
+ dohtml -r doc/*
+ prepgamesdirs
+}