summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-12-04 19:07:12 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-12-04 19:07:12 +0000
commit586d275c90026521b985b698675552e4c6c0803b (patch)
treeb231fbaa684fd28bd56619dbe1e8409af7c52b54 /games-strategy
parentalpha stable wrt #200097, thanks to Tobias Klausmann for testing (diff)
downloadgentoo-2-586d275c90026521b985b698675552e4c6c0803b.tar.gz
gentoo-2-586d275c90026521b985b698675552e4c6c0803b.tar.bz2
gentoo-2-586d275c90026521b985b698675552e4c6c0803b.zip
Version bump
(Portage version: 2.1.4_rc6)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog7
-rw-r--r--games-strategy/warzone2100/files/digest-warzone2100-2.0.93
-rw-r--r--games-strategy/warzone2100/warzone2100-2.0.9.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index c32993b7329d..98f181be7e04 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.16 2007/07/01 18:09:17 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.17 2007/12/04 19:07:11 nyhm Exp $
+
+*warzone2100-2.0.9 (04 Dec 2007)
+
+ 04 Dec 2007; Tristan Heaven <nyhm@gentoo.org> +warzone2100-2.0.9.ebuild:
+ Version bump
*warzone2100-2.0.7-r1 (01 Jul 2007)
diff --git a/games-strategy/warzone2100/files/digest-warzone2100-2.0.9 b/games-strategy/warzone2100/files/digest-warzone2100-2.0.9
new file mode 100644
index 000000000000..95a160181700
--- /dev/null
+++ b/games-strategy/warzone2100/files/digest-warzone2100-2.0.9
@@ -0,0 +1,3 @@
+MD5 fbf869a88987bdbd945979eb0a83088d warzone2100-2.0.9.tar.bz2 13174205
+RMD160 e1da76d6640ebca29c401b06a16cf531a26bb951 warzone2100-2.0.9.tar.bz2 13174205
+SHA256 68adb2a4fbffb5c97b6fa948ae08b18fcb73992b5540b2e3fd71743f73bd6ddb warzone2100-2.0.9.tar.bz2 13174205
diff --git a/games-strategy/warzone2100/warzone2100-2.0.9.ebuild b/games-strategy/warzone2100/warzone2100-2.0.9.ebuild
new file mode 100644
index 000000000000..5a3cc15b9238
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.0.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.0.9.ebuild,v 1.1 2007/12/04 19:07:11 nyhm Exp $
+
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="http://download.gna.org/warzone/releases/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+# upstream requested debug support
+IUSE="debug mp3"
+
+RDEPEND="dev-games/physfs
+ media-libs/jpeg
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/libvorbis
+ >=media-libs/openal-0.0.8-r1
+ media-libs/sdl-net
+ virtual/glu
+ virtual/opengl
+ mp3? ( media-libs/libmad )"
+DEPEND="${RDEPEND}
+ app-arch/zip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i '/^dist_doc_DATA/s:COPYING.*$:TODO:' Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ --with-ogg=/usr \
+ --with-vorbis=/usr \
+ --enable-ogg \
+ $(use_enable mp3) \
+ $(use_enable debug) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepalldocs
+ prepgamesdirs
+}