summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-05 23:18:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-05 23:18:59 +0000
commit2541931bfd2cf754ecbc15cd4e4b79bc604409ce (patch)
treeaf6ae90fb769875a051e6de0ee34f5bd50c1eb57 /games-strategy
parentadd sudo dep (Manifest recommit) (diff)
downloadgentoo-2-2541931bfd2cf754ecbc15cd4e4b79bc604409ce.tar.gz
gentoo-2-2541931bfd2cf754ecbc15cd4e4b79bc604409ce.tar.bz2
gentoo-2-2541931bfd2cf754ecbc15cd4e4b79bc604409ce.zip
add a patch to work around the broken version checking for libphysfs (bug #48831)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/netpanzer/ChangeLog7
-rw-r--r--games-strategy/netpanzer/files/physfs.patch21
-rw-r--r--games-strategy/netpanzer/netpanzer-0.1.5.ebuild10
3 files changed, 36 insertions, 2 deletions
diff --git a/games-strategy/netpanzer/ChangeLog b/games-strategy/netpanzer/ChangeLog
index 297777c6f10e..cf2072aa8972 100644
--- a/games-strategy/netpanzer/ChangeLog
+++ b/games-strategy/netpanzer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/netpanzer
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/ChangeLog,v 1.7 2004/03/06 00:45:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/ChangeLog,v 1.8 2004/05/05 23:18:59 mr_bones_ Exp $
+
+ 05 May 2004; Michael Sterrett <mr_bones_@gentoo.org> netpanzer-0.1.5.ebuild,
+ files/physfs.patch:
+ add a patch to work around the broken version checking for libphysfs (bug
+ #48831)
*netpanzer-0.1.5 (05 Mar 2004)
diff --git a/games-strategy/netpanzer/files/physfs.patch b/games-strategy/netpanzer/files/physfs.patch
new file mode 100644
index 000000000000..c77151bec6ba
--- /dev/null
+++ b/games-strategy/netpanzer/files/physfs.patch
@@ -0,0 +1,21 @@
+--- configure.ac.orig 2004-05-05 15:44:04.000000000 -0700
++++ configure.ac 2004-05-05 15:45:37.000000000 -0700
+@@ -118,8 +118,9 @@
+ [AC_MSG_ERROR([Please install SDLImage >= 1.2.1])],
+ [$SDL_CFLAGS], [$SDL_LIBS])
+
+-NP_FINDLIB([PHYSFS], [physfs], [physfs >= 1.9],
++NP_FINDLIB([PHYSFS], [physfs], [physfs >= 0.1.9],
+ NP_LANG_PROGRAM([#include <physfs.h>
++#if PHYSFS_VER_MAJOR < 1
+ #if PHYSFS_VER_MINOR < 1
+ # error PHYSFS is too old
+ #else
+@@ -128,6 +129,7 @@
+ # error PHYSFS is too old
+ # endif
+ # endif
++#endif
+ #endif]),
+ [], [-lphysfs],
+ [],
diff --git a/games-strategy/netpanzer/netpanzer-0.1.5.ebuild b/games-strategy/netpanzer/netpanzer-0.1.5.ebuild
index e7b61fc8ef9e..cf4325607c5c 100644
--- a/games-strategy/netpanzer/netpanzer-0.1.5.ebuild
+++ b/games-strategy/netpanzer/netpanzer-0.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.1.5.ebuild,v 1.1 2004/03/06 00:45:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.1.5.ebuild,v 1.2 2004/05/05 23:18:59 mr_bones_ Exp $
inherit eutils games
@@ -25,10 +25,18 @@ RDEPEND=">=media-libs/libsdl-1.2.5
DEPEND="${RDEPEND}
>=dev-util/jam-2.5"
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/${PN}data-${DATAVERSION}/
+ epatch "${FILESDIR}/physfs.patch"
+ ./autogen.sh
+}
+
src_compile() {
egamesconf || die
jam || die "jam failed"
+ einfo "working in ${WORKDIR}/${PN}data-${DATAVERSION}/"
cd ${WORKDIR}/${PN}data-${DATAVERSION}/
egamesconf || die
jam || die "jam failed (on data package)"