summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-14 03:28:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-14 03:28:30 +0000
commit1a0f7aed17a656232266200256f248784abad427 (patch)
treee858d81e471197213f3b1afd6ee2222f19ba3c3c /games-strategy
parentMove the sed line to src_prepare for more portability (diff)
downloadgentoo-2-1a0f7aed17a656232266200256f248784abad427.tar.gz
gentoo-2-1a0f7aed17a656232266200256f248784abad427.tar.bz2
gentoo-2-1a0f7aed17a656232266200256f248784abad427.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog8
-rw-r--r--games-strategy/warzone2100/warzone2100-2.2.3.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index f29c793dc8ea..c605f58b9304 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.34 2009/08/26 08:42:16 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.35 2009/09/14 03:28:30 mr_bones_ Exp $
+
+*warzone2100-2.2.3 (14 Sep 2009)
+
+ 14 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.2.3.ebuild:
+ version bump
*warzone2100-2.2.2 (26 Aug 2009)
diff --git a/games-strategy/warzone2100/warzone2100-2.2.3.ebuild b/games-strategy/warzone2100/warzone2100-2.2.3.ebuild
new file mode 100644
index 000000000000..1d45079361ec
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.2.3.ebuild,v 1.1 2009/09/14 03:28:30 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( http://download.gna.org/warzone/videos/sequences-${MY_PV}.wz )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ || ( >=dev-games/physfs-2[zip] <dev-games/physfs-2 )
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/sequences-${MY_PV}.wz sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}