summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-05-30 08:32:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-05-30 08:32:59 +0000
commit1369509f598e52107d80a2988a077b9825e1d3d2 (patch)
tree82222512b0bbb4bbb5f3f3a327f079c60b104207 /games-strategy
parentSecurity bump. CVE-2012-2098 #417909 (diff)
downloadgentoo-2-1369509f598e52107d80a2988a077b9825e1d3d2.tar.gz
gentoo-2-1369509f598e52107d80a2988a077b9825e1d3d2.tar.bz2
gentoo-2-1369509f598e52107d80a2988a077b9825e1d3d2.zip
Fix build failure against gcc-4.7 (missing prototypes)
(Portage version: 2.2.0_alpha108_p3/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/scorched3d/ChangeLog6
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.3d-gcc47.patch21
-rw-r--r--games-strategy/scorched3d/scorched3d-43.3d.ebuild5
3 files changed, 29 insertions, 3 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index c17bef140518..2189f7a99e4c 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.84 2012/05/13 19:32:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.85 2012/05/30 08:32:58 slyfox Exp $
+
+ 30 May 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/scorched3d-43.3d-gcc47.patch, scorched3d-43.3d.ebuild:
+ Fix build failure against gcc-4.7 (missing prototypes)
13 May 2012; Michael Sterrett <mr_bones_@gentoo.org>
+files/scorched3d-43.3d-gcc43.patch, +files/scorched3d-43.3d-odbc.patch,
diff --git a/games-strategy/scorched3d/files/scorched3d-43.3d-gcc47.patch b/games-strategy/scorched3d/files/scorched3d-43.3d-gcc47.patch
new file mode 100644
index 000000000000..fffd5c72685c
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.3d-gcc47.patch
@@ -0,0 +1,21 @@
+Fix build failure against gcc-4.7 (missing <unistd.h> for close())
+
+../client/SecureID.cpp: In member function 'std::string SecureID::GetPrivateKey()':
+../client/SecureID.cpp:92:13: error: 'close' was not declared in this scope
+../client/SecureID.cpp:102:14: error: 'close' was not declared in this scope
+../client/SecureID.cpp:115:13: error: 'close' was not declared in this scope
+../client/SecureID.cpp:124:12: error: 'close' was not declared in this scope
+
+make[3]: *** [SecureID.o] Error 1
+diff --git a/src/client/client/SecureID.cpp b/src/client/client/SecureID.cpp
+index bc276c4..5eb2f13 100644
+--- a/src/client/client/SecureID.cpp
++++ b/src/client/client/SecureID.cpp
+@@ -75,6 +75,7 @@ std::string SecureID::GetPrivateKey(void)
+
+ #include <sys/ioctl.h>
+ #include <net/if.h>
++#include <unistd.h>
+
+ std::string SecureID::GetPrivateKey(void)
+ {
diff --git a/games-strategy/scorched3d/scorched3d-43.3d.ebuild b/games-strategy/scorched3d/scorched3d-43.3d.ebuild
index 66a393ebca90..4d8e4a7ce842 100644
--- a/games-strategy/scorched3d/scorched3d-43.3d.ebuild
+++ b/games-strategy/scorched3d/scorched3d-43.3d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-43.3d.ebuild,v 1.2 2012/05/13 19:32:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-43.3d.ebuild,v 1.3 2012/05/30 08:32:58 slyfox Exp $
EAPI=2
WX_GTK_VER=2.8
@@ -41,7 +41,8 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-odbc.patch \
"${FILESDIR}"/${P}-png15.patch \
- "${FILESDIR}"/${P}-win32.patch
+ "${FILESDIR}"/${P}-win32.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
eautoreconf
}