summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-06 02:05:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-06 02:05:52 +0000
commit0a9efc14fefdafcaf74c1488b9c14b2e9f77a029 (patch)
treeff3cfea4beb7274a9fbf998448bf4b0bf7f7f3df /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-0a9efc14fefdafcaf74c1488b9c14b2e9f77a029.tar.gz
gentoo-2-0a9efc14fefdafcaf74c1488b9c14b2e9f77a029.tar.bz2
gentoo-2-0a9efc14fefdafcaf74c1488b9c14b2e9f77a029.zip
masked version bump
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.1.113
-rw-r--r--games-strategy/wesnoth/wesnoth-1.1.11.ebuild86
3 files changed, 96 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 3a3d3b1f72e3..e7170b83c906 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.77 2006/09/21 05:25:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.78 2006/10/06 02:05:52 mr_bones_ Exp $
+
+*wesnoth-1.1.11 (06 Oct 2006)
+
+ 06 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-1.1.11.ebuild:
+ masked version bump
*wesnoth-1.1.10 (21 Sep 2006)
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.1.11 b/games-strategy/wesnoth/files/digest-wesnoth-1.1.11
new file mode 100644
index 000000000000..d38015429a95
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.1.11
@@ -0,0 +1,3 @@
+MD5 ebd1e7407d8f888a7ea40afa407b8aca wesnoth-1.1.11.tar.gz 77011568
+RMD160 cdc85b6c93e0da17e7e0a279e638896c5e7a04df wesnoth-1.1.11.tar.gz 77011568
+SHA256 ed1b89946843735ae3e222e6f5815595a6c6a29d054bd42e37d95ebb415c2fe7 wesnoth-1.1.11.tar.gz 77011568
diff --git a/games-strategy/wesnoth/wesnoth-1.1.11.ebuild b/games-strategy/wesnoth/wesnoth-1.1.11.ebuild
new file mode 100644
index 000000000000..69e04fbdb6ca
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.1.11.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.11.ebuild,v 1.1 2006/10/06 02:05:52 mr_bones_ Exp $
+
+inherit autotools eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ !dedicated? (
+ x11-libs/libX11
+ >=media-libs/freetype-2 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-net
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
+ die "Please emerge sdl-mixer with USE=vorbis"
+ fi
+ if ! built_with_use media-libs/sdl-image png ; then
+ die "Please emerge sdl-image with USE=png"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+ if use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-fribidi \
+ --with-localedir=/usr/share/locale \
+ --with-icondir=/usr/share/icons \
+ --with-desktopdir=/usr/share/applications \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_enable nls dummy-locales) \
+ $(use_enable !dedicated game) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc MANUAL changelog
+ if use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}