summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-12 16:18:21 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-12 16:18:21 +0000
commit338960246c41db6b910bcc5ab1dd8a08b4e39431 (patch)
tree49bf245a7462dc9064fee8c43e7859c9d3605fd0 /games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild
parentVersion bump, wrt to bug #139765 (diff)
downloadgentoo-2-338960246c41db6b910bcc5ab1dd8a08b4e39431.tar.gz
gentoo-2-338960246c41db6b910bcc5ab1dd8a08b4e39431.tar.bz2
gentoo-2-338960246c41db6b910bcc5ab1dd8a08b4e39431.zip
Install missing files, bug #154812
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild')
-rw-r--r--games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild b/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..e67f534bc049
--- /dev/null
+++ b/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild,v 1.1 2006/11/12 16:18:21 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="A multi-player game of strategy and coordination"
+HOMEPAGE="http://www.lysator.liu.se/~mbrx/XBattleAI/index.html"
+SRC_URI="http://www.lysator.liu.se/~mbrx/XBattleAI/${P}.tgz"
+
+LICENSE="xbattle"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Since this uses similar code and the same binary name as the original XBattle,
+# we want to make sure you can't install both at the same time
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11
+ dev-lang/tcl
+ dev-lang/tk
+ !games-strategy/xbattle"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ app-text/rman
+ x11-misc/imake"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f xbcs/foo.xbc~
+ epatch "${FILESDIR}"/${P}-sandbox.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ mv "${D}/${GAMES_BINDIR}"/{,xb_}gauntletCampaign
+ dodoc CONTRIBUTORS README README.AI TODO xbattle.dot
+ prepgamesdirs
+}