summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
commit0c0186e57f9c188f3c71c04a35825c8e134cf141 (patch)
tree764612f703bdba5335d790064606b1f53a330c24 /games-strategy/xarchon/xarchon-0.50.ebuild
parentminor version update. resolves bug 27641 (diff)
downloadgentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.tar.gz
gentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.tar.bz2
gentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.zip
mmm strategy games
Diffstat (limited to 'games-strategy/xarchon/xarchon-0.50.ebuild')
-rw-r--r--games-strategy/xarchon/xarchon-0.50.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-strategy/xarchon/xarchon-0.50.ebuild b/games-strategy/xarchon/xarchon-0.50.ebuild
new file mode 100644
index 000000000000..a1912f34aceb
--- /dev/null
+++ b/games-strategy/xarchon/xarchon-0.50.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xarchon/xarchon-0.50.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="modelled after the golden oldie Archon game"
+HOMEPAGE="http://xarchon.seul.org/"
+SRC_URI="ftp://ftp.seul.org/pub/xarchon/${P}.tar.gz
+ http://xarchon.seul.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="esd joystick"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1*
+ esd? ( media-sound/esound )"
+
+src_compile() {
+ local mysndconf
+ [ `use esd` ] \
+ && mysndconf="--with-esd-prefix=/usr" \
+ || mysndconf="--disable-sound"
+ egamesconf \
+ --enable-network \
+ `use_enable joystick` \
+ ${mysndconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ egamesinstall || die
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
+}