summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-10-04 14:52:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-10-04 14:52:46 +0000
commitac41373f102371f0b08097eab42c4f2e190ab9f0 (patch)
treeb39869ad630257602fb657bee961cc94c9077b8a /games-strategy/wesnoth
parentUpdate inittab to bind agetty at least to tty1 for single mode. Noted by Riv... (diff)
downloadgentoo-2-ac41373f102371f0b08097eab42c4f2e190ab9f0.tar.gz
gentoo-2-ac41373f102371f0b08097eab42c4f2e190ab9f0.tar.bz2
gentoo-2-ac41373f102371f0b08097eab42c4f2e190ab9f0.zip
version bumpversion bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.01
-rw-r--r--games-strategy/wesnoth/wesnoth-1.0.ebuild52
3 files changed, 55 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index c5a39e32171d..d5f8b744ffb9 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 57059bb5bc220cf8bcc5756fc97f55e5 wesnoth-0.9.7.ebuild 1304
MD5 8db58a8f70a15e32d9e253b21466fb7d wesnoth-0.9.6.ebuild 1304
+MD5 57059bb5bc220cf8bcc5756fc97f55e5 wesnoth-1.0.ebuild 1304
MD5 314df4e4f0d21a1c55cb8150c433126e ChangeLog 8477
MD5 ed05bdc0d65c5396b06d15c667e260fc files/digest-wesnoth-0.9.6 67
+MD5 b6b7714f976baa5d256c2f910992da4a files/digest-wesnoth-1.0 65
MD5 fb1fa5b4b8d2cf8cb254199744d05a69 files/digest-wesnoth-0.9.7 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.0 b/games-strategy/wesnoth/files/digest-wesnoth-1.0
new file mode 100644
index 000000000000..e73ded28bc77
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.0
@@ -0,0 +1 @@
+MD5 ce9fa39f6a5b01f55eceb6c13de2b62d wesnoth-1.0.tar.gz 37375056
diff --git a/games-strategy/wesnoth/wesnoth-1.0.ebuild b/games-strategy/wesnoth/wesnoth-1.0.ebuild
new file mode 100644
index 000000000000..50cfbf29083b
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.0.ebuild,v 1.1 2005/10/04 14:52:46 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localedir=/usr/share/locale \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ if use server ; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ fi
+ dodoc MANUAL changelog
+ prepgamesdirs
+}