summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-05-20 21:21:58 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-05-20 21:21:58 +0000
commit8c1c0a0816e88e4dc5d4b724cc45c3371cc9e64d (patch)
tree2366598f2165907cbdbae9f05f13799019bbb440 /games-strategy/outerspace
parentalpha stable wrt #1777422 and remove old (diff)
downloadgentoo-2-8c1c0a0816e88e4dc5d4b724cc45c3371cc9e64d.tar.gz
gentoo-2-8c1c0a0816e88e4dc5d4b724cc45c3371cc9e64d.tar.bz2
gentoo-2-8c1c0a0816e88e4dc5d4b724cc45c3371cc9e64d.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-strategy/outerspace')
-rw-r--r--games-strategy/outerspace/ChangeLog7
-rw-r--r--games-strategy/outerspace/files/digest-outerspace-0.5.623
-rw-r--r--games-strategy/outerspace/outerspace-0.5.62.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index 866dc7dfb300..aacd7d860a43 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.4 2007/02/26 23:50:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.5 2007/05/20 21:21:58 nyhm Exp $
+
+*outerspace-0.5.62 (20 May 2007)
+
+ 20 May 2007; Tristan Heaven <nyhm@gentoo.org> +outerspace-0.5.62.ebuild:
+ Version bump
*outerspace-0.5.61 (26 Feb 2007)
diff --git a/games-strategy/outerspace/files/digest-outerspace-0.5.62 b/games-strategy/outerspace/files/digest-outerspace-0.5.62
new file mode 100644
index 000000000000..3b46166bea8e
--- /dev/null
+++ b/games-strategy/outerspace/files/digest-outerspace-0.5.62
@@ -0,0 +1,3 @@
+MD5 78991ccfab46dd8c58a09891ab2eeaf7 OuterSpace-0.5.62.tar.gz 1667207
+RMD160 0c9e4fc3220eb79e3ee606693f96c7ac483488bb OuterSpace-0.5.62.tar.gz 1667207
+SHA256 6956ac86662539f88c8aec0b7f5c4d62ee78aff9600379f141169acf4e109550 OuterSpace-0.5.62.tar.gz 1667207
diff --git a/games-strategy/outerspace/outerspace-0.5.62.ebuild b/games-strategy/outerspace/outerspace-0.5.62.ebuild
new file mode 100644
index 000000000000..875f81806d8d
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.62.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.62.ebuild,v 1.1 2007/05/20 21:21:58 nyhm Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}