summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-16 12:21:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-16 12:21:34 +0000
commit9bafba06382d8843feb3647abe52dd6aa6d30aaa (patch)
tree91fb5272440d43c475b4fd33124b6660a3fcdc2f /games-strategy/netpanzer
parentKeyword ~ppc ~ppc64, request by Pinkbyte (diff)
downloadgentoo-2-9bafba06382d8843feb3647abe52dd6aa6d30aaa.tar.gz
gentoo-2-9bafba06382d8843feb3647abe52dd6aa6d30aaa.tar.bz2
gentoo-2-9bafba06382d8843feb3647abe52dd6aa6d30aaa.zip
Fix build with gcc-4.7 Bug #422767
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/netpanzer')
-rw-r--r--games-strategy/netpanzer/ChangeLog7
-rw-r--r--games-strategy/netpanzer/files/netpanzer-0.8.2-gcc47.patch11
-rw-r--r--games-strategy/netpanzer/netpanzer-0.8.2.ebuild15
3 files changed, 26 insertions, 7 deletions
diff --git a/games-strategy/netpanzer/ChangeLog b/games-strategy/netpanzer/ChangeLog
index ae1aa9a630f2..4756899e654f 100644
--- a/games-strategy/netpanzer/ChangeLog
+++ b/games-strategy/netpanzer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/netpanzer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/ChangeLog,v 1.33 2012/09/12 08:33:00 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/ChangeLog,v 1.34 2012/10/16 12:21:34 tupone Exp $
+
+ 16 Oct 2012; Alfredo Tupone <tupone@gentoo.org> netpanzer-0.8.2.ebuild,
+ +files/netpanzer-0.8.2-gcc47.patch:
+ Fix build with gcc-4.7 Bug #422767 by Diego
+ Migration to EAPI 4
12 Sep 2012; Tupone Alfredo <tupone@gentoo.org> netpanzer-0.8.2.ebuild:
Handle AR properly. Fix Bug #429156 by Diego
diff --git a/games-strategy/netpanzer/files/netpanzer-0.8.2-gcc47.patch b/games-strategy/netpanzer/files/netpanzer-0.8.2-gcc47.patch
new file mode 100644
index 000000000000..432f40a9f9aa
--- /dev/null
+++ b/games-strategy/netpanzer/files/netpanzer-0.8.2-gcc47.patch
@@ -0,0 +1,11 @@
+--- src/Lib/ArrayUtil/QueueTemplate.hpp.old 2012-10-16 13:57:33.000000000 +0200
++++ src/Lib/ArrayUtil/QueueTemplate.hpp 2012-10-16 13:58:16.000000000 +0200
+@@ -42,7 +42,7 @@
+
+ bool enqueue(const TYPE& object )
+ {
+- add( object, (rear + 1) % this->size );
++ this->add( object, (rear + 1) % this->size );
+ rear = (rear + 1) % this->size;
+
+ if ( front == rear )
diff --git a/games-strategy/netpanzer/netpanzer-0.8.2.ebuild b/games-strategy/netpanzer/netpanzer-0.8.2.ebuild
index c09e5a9edb43..3db25e94b3ce 100644
--- a/games-strategy/netpanzer/netpanzer-0.8.2.ebuild
+++ b/games-strategy/netpanzer/netpanzer-0.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.8.2.ebuild,v 1.9 2012/09/12 08:33:00 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.8.2.ebuild,v 1.10 2012/10/16 12:21:34 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils games
DATAVERSION="0.8"
@@ -24,7 +24,10 @@ RDEPEND="dedicated? ( app-misc/screen )
DEPEND="${RDEPEND}
dev-util/ftjam"
-PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+)
src_configure() {
egamesconf || die
@@ -48,7 +51,7 @@ src_install() {
|| die "jam install failed (data package)"
if use dedicated ; then
- newinitd "${FILESDIR}"/${PN}.rc ${PN} || die "newinitd failed"
+ newinitd "${FILESDIR}"/${PN}.rc ${PN}
sed -i \
-e "s:GAMES_USER_DED:${GAMES_USER_DED}:" \
-e "s:GENTOO_DIR:${GAMES_BINDIR}:" \
@@ -56,8 +59,8 @@ src_install() {
|| die "sed failed"
insinto /etc
- doins "${FILESDIR}"/${PN}-ded.ini || die "doins failed"
- dogamesbin "${FILESDIR}"/${PN}-ded || die "dogamesbin failed"
+ doins "${FILESDIR}"/${PN}-ded.ini
+ dogamesbin "${FILESDIR}"/${PN}-ded
sed -i \
-e "s:GENTOO_DIR:${GAMES_BINDIR}:" \
"${D}/${GAMES_BINDIR}"/${PN}-ded \